Discussion on BeoUI - Complete Mobile UI template for React Native

19 comments found.

Are your products for Programmers only?

Yes, it’s used for React Native mobile programmer who want to speed up their development process.

Yes, it’s used for React Native mobile programmer who want to speed up their development process.

this is will be complete app soon or what?

This will be updated more UI features, if you want to try full application you may love the BeoStore product

but i have hte beostore product ( full app) but if i wanna the app with this design can u make it for me?

yeah, i can support you with low cost to rebrand the app and upgrade the app UI to match with your website

Excellent GLWS ;)

Thank you man :)

Im familiar with Android Studio and CLI but I want to know, will there be a lot of coding involved to use this product?

as so far it is just an UI template, if you would like to use and customize the full mobile application, you can try BeoStore product which is required less coding skill :)

OK thanks, I will check it out.

ccir105

ccir105 Purchased

I got this and could not install

npm ERR! Linux 3.13.0-36-generic npm ERR! argv ”/usr/bin/nodejs” ”/usr/bin/npm” “install” npm ERR! node v5.12.0 npm ERR! npm v3.8.6

npm ERR! shasum check failed for /tmp/npm-18605-64afec72/registry.npmjs.org/react-native-animated-tabs/-/react-native-animated-tabs-1.1.0.tgz npm ERR! Expected: 9cf84929934feac5c3f9450514fe98c0bdd72b01 npm ERR! Actual: 529a6a7ab8411d5bf2977504f00f9ce590f33ca8 npm ERR! From: https://registry.npmjs.org/react-native-animated-tabs/-/react-native-animated-tabs-1.1.0.tgz npm ERR! npm ERR! If you need help, you may report this error at: npm ERR! <https://github.com/npm/npm/issues>

npm ERR! Please include the following file with any support request: npm ERR! /home/ccir105/projects/mo/BeoUI/npm-debug.log

ccir105

ccir105 Purchased

I am still getting problem while running react-native run-android. I have already connected the device but its says connect the device or emulator.

Running /home/ccir105/Android/Sdk/platform-tools/adb -s 41006360f2918191 reverse tcp:8081 tcp:8081 Building and installing the app on the device (cd android && ./gradlew installDebug)...

Could not install the app on the device, read the error above for details. Make sure you have an Android emulator running or a device connected and have set up your Android development environment: https://facebook.github.io/react-native/docs/android-setup.html

Is something wrong on my setup ? When I build my older react-native 0.38 app it is working but it wont work with yours 0.39

This issue happen sometime with React Native, you can try this solution:

- close the simulator

- delete node_modules folder

- clear npm cache and watchman: npm cache clean, watchman watch-del-all

- run npm install or yarn install and run-android again

ccir105

ccir105 Purchased

I did it manually, bash gradlew installDebug and it worked. Thanks

d_40s

d_40s Purchased

Hi,

I couldn’t run android version, got this error :

Building and installing the app on the device (cd android && ./gradlew installDebug)...

FAILURE: Build failed with an exception.

  • What went wrong: A problem occurred configuring project ’:app’. > The SDK directory ’/Users/minh/Library/Android/sdk’ does not exist.
  • Try: Run with—stacktrace option to get the stack trace. Run with—info or—debug option to get more log output.

BUILD FAILED

Total time: 13.565 secs

I’ve tried your solution

- close the simulator - delete node_modules folder - clear npm cache and watchman: npm cache clean, watchman watch-del-all - run npm install or yarn install and run-android again

But still got same error, What’s wrong ? I’m using react native version 0.39.2

Hi, you can fix this issue by change the sdk.dir to your local Android SDK – https://gyazo.com/632e068ae59da60c9c530ddc2baadb20

alsalo

alsalo Purchased

I hope to help Image attachment

https://up.harajgulf.com/do.php?img=1472935

Hi, please run “

yarn install
or
npm install 
to install the dependencies first then: start the node server
yarn start
before run
react-native run-ios

hi please help me, i got this error when run ./gradlew assembleRelease ...... :app:processReleaseManifest :app:processReleaseResources /home/aceng/Documents/BeoUI/android/app/build/intermediates/res/merged/release/drawable-mdpi/app_images_woman7.jpg: error: Duplicate file. /home/aceng/Documents/BeoUI/android/app/build/intermediates/res/merged/release/drawable-mdpi-v4/app_images_woman7.jpg: Original is here. The version qualifier may be implied.

:app:processReleaseResources FAILED

FAILURE: Build failed with an exception.

  • What went wrong: Execution failed for task ’:app:processReleaseResources’. > com.android.ide.common.process.ProcessException: Failed to execute aapt
  • Try: Run with—stacktrace option to get the stack trace. Run with—info or—debug option to get more log output.

BUILD FAILED

Total time: 57.573 secs

How, how about running:

react-native run-android
?, please make sure you have run the init project successful as well from this guide https://facebook.github.io/react-native/docs/getting-started.html

I am interested in the UI part. Dont need the ecommerce or wordpress apps that you have in the portfolio. So the question is – Does this product BeoUI include all the UI elements that are there in the other 2 apps also? Which app to buy if one needs all the components of react native

Hi, all the UI elements were list out from the screenshots, we will try to improve more by adding extra components later, like the map view. animation parts…

i would buy the template, for now i tested the beo store, and i can see a transitions between search and category components, are they included in this template?

Hi, do you mean the sticky header search when scrolling down and up? It’s also included from the template.

is there a demo for this ?

barjas

barjas Purchased

sorry for all the questions, but how to upgrade react native to 0.43? “react-native-git-upgrade” is not working for this .

you are very welcome, we will upgrade to RN soon on next version release. you may need to change the package json with new 0.43 then it could work.

barjas

barjas Purchased

any timeline for that ?

Do you support RTL language?

Hi, it’s not support RTL so far.

have backend?

Hi, it’s the UI only, we also have other product call BeoStore which have the backend :)

Hello, I would like to know where I edit the interface color.

Thanks!

I would like to change the color of this icon, as shown:

http://oi63.tinypic.com/2duicti.jpg Thanks

Hi, could you please take the whole screenshot, i could not know where the screen?

Hello, It’s the default home of the app, with the display options.

Hi, Are there free upgrades or your future versions ?

Hi, we’s just release new version for BeoUI, if you have already purchase, it is free upgrade. Thank you!

mnrdwt

mnrdwt Purchased

Great, an update! :)

Getting a lot of errors though:

npm install npm WARN Invalid version: "2.0" npm WARN beoui-expo No description npm WARN beoui-expo No repository field. npm WARN beoui-expo No README data npm WARN beoui-expo No license field.

Removing

"version": "2.0",

from package.json, npm install works, some errors though:

│ └── UNMET PEER DEPENDENCY react@^0.13.0 || ^0.14.0 || ^15.0.0

Opening in Expo:

jest-haste-map: @providesModule naming collision: Duplicate module name: react-native Paths: /Users/xxx/Documents/rn/beoui-expo/node_modules/react-native/package.json collides with /Users/xxx/Documents/rn/beoui-expo/node_modules/react-native-router-flux/node_modules/react-native/package.json This warning is caused by a @providesModule declaration with the same name across two different files. and Failed to build DependencyGraph: @providesModule naming collision: Duplicate module name: react-native-vector-icons Paths: /Users/xxx/Documents/rn/beoui-expo/node_modules/react-native/local-cli/core/__fixtures__/files/package.json collides with /Users/xxx/Documents/rn/beoui-expo/node_modules/react-native-router-flux/node_modules/react-native/local-cli/core/__fixtures__/files/package.json This error is caused by a @providesModule declaration with the same name across two different files. Error: @providesModule naming collision: Duplicate module name: react-native-vector-icons Paths: /Users/xxx/Documents/rn/beoui-expo/node_modules/react-native/local-cli/core/__fixtures__/files/package.json collides with /Users/xxx/Documents/rn/beoui-expo/node_modules/react-native-router-flux/node_modules/react-native/local-cli/core/__fixtures__/files/package.json This error is caused by a @providesModule declaration with the same name across two different files. at HasteMap._updateHasteMap (/Users/xxx/Documents/rn/beoui-expo/node_modules/react-native/packager/src/node-haste/DependencyGraph/HasteMap.js:159:13) at p.getName.then.name (/Users/xxx/Documents/rn/beoui-expo/node_modules/react-native/packager/src/node-haste/DependencyGraph/HasteMap.js:134:31)

Am I doing something wrong here?

Removed node_modules multiple times, tried installed using yarn, clear npm cache, but still getting the errors

Hi, please remove the node_module from beoui-expo/node_modules/react-native-router-flux will fix the issues. Btw, after starting installing the library you can use Expo to run the app, document is updated from – https://minhcasi.gitbooks.io/beoui/content/getting-started.html

Can you add media player comments!?

by
by
by
by
by
by