itswadesh

itswadesh does not currently provide support for this item.

71 comments found.

Hi, I need to know.

If I’ll purchase mCRUD, I will able to modify the code anywere? Add features?, make changes in any part of the code?

Please confirm me!!!

Thanks in advance.

Yes. I will provide you the development version which is open for modifications as long as it satisfies the license.

Hi itswadesh, last question, the price for development version is the same as regular version?

Yes. As long as you are not selling the developed app (as per envato license terms)

teter

teter Purchased

I have purchased this item and seems to work, but when i can do npm test, i get this error everytime. I have tried linux and windows.

Running “mochaTest:unit” (mochaTest) task >> Mocha exploded! >> TypeError: router.use is not a function >> at Object.<anonymous> (/home/cpc/Escritorio/mcrud/server/api/media/index.js:8:8) >> at Module._compile (module.js:410:26) >> at normalLoader (/home/cpc/Escritorio/mcrud/node_modules/babel-core/lib/api/register/node.js:199:5) >> at Object.require.extensions.(anonymous function) [as .js] (/home/cpc/Escritorio/mcrud/node_modules/babel-core/lib/api/register/node.js:216:7) >> at Object.require.extensions.(anonymous function) (/home/cpc/Escritorio/mcrud/node_modules/proxyquire/lib/proxyquire.js:259:43) >> at Module.load (module.js:344:32) >> at Function.Module._load (module.js:301:12) >> at Module.require (module.js:354:17) >> at Proxyquire._withoutCache (/home/cpc/Escritorio/mcrud/node_modules/proxyquire/lib/proxyquire.js:179:12) >> at Proxyquire.load (/home/cpc/Escritorio/mcrud/node_modules/proxyquire/lib/proxyquire.js:136:15) >> at Object.<anonymous> (/home/cpc/Escritorio/mcrud/server/api/media/index.spec.js:22:18) >> at Module._compile (module.js:410:26) >> at normalLoader (/home/cpc/Escritorio/mcrud/node_modules/babel-core/lib/api/register/node.js:199:5) >> at Object.require.extensions.(anonymous function) [as .js] (/home/cpc/Escritorio/mcrud/node_modules/babel-core/lib/api/register/node.js:216:7) >> at Module.load (module.js:344:32) >> at Function.Module._load (module.js:301:12) Warning: Task “mochaTest:unit” failed. Use—force to continue.

Aborted due to warnings.

Hi. Sorry to inform you that you need to write the tests.

fred67

fred67 Purchased

Hi … i need the developer version to add some features to my app … thanks.

Hi. This is the developer version

Hi, i followed the steps in documentation but i cant made it work. When When i start the server using “grunt serve”: Running “serve” task

jit-grunt: Plugin for the If you have installed the See https://github.com/sh

Warning: Task “clean:serv

Aborted due to warnings.

If i used “grunt serve—force”: Running “serve” task

jit-grunt: Plugin for the “clean” task not found. If you have installed the plugin already, please setting the static mapping. See https://github.com/shootaroo/jit-grunt#static-mappings

Warning: Task “clean:server” failed. Used—force, continuing.

jit-grunt: Plugin for the “env” task not found. If you have installed the plugin already, please setting the static mapping. See https://github.com/shootaroo/jit-grunt#static-mappings

Warning: Task “env:all” failed. Used—force, continuing.

jit-grunt: Plugin for the “concurrent” task not found. If you have installed the plugin already, please setting the static mapping. See https://github.com/shootaroo/jit-grunt#static-mappings

Warning: Task “concurrent:pre” failed. Used—force, continuing.

jit-grunt: Plugin for the “concurrent” task not found. If you have installed the plugin already, please setting the static mapping. See https://github.com/shootaroo/jit-grunt#static-mappings

Warning: Task “concurrent:server” failed. Used—force, continuing.

jit-grunt: Plugin for the “injector” task not found. If you have installed the plugin already, please setting the static mapping. See https://github.com/shootaroo/jit-grunt#static-mappings

Warning: Task “injector” failed. Used—force, continuing.

jit-grunt: Plugin for the “wiredep” task not found. If you have installed the plugin already, please setting the static mapping. See https://github.com/shootaroo/jit-grunt#static-mappings

Warning: Task “wiredep:client” failed. Used—force, continuing.

jit-grunt: Plugin for the “postcss” task not found. If you have installed the plugin already, please setting the static mapping. See https://github.com/shootaroo/jit-grunt#static-mappings

Warning: Task “postcss” failed. Used—force, continuing.

jit-grunt: Plugin for the “express” task not found. If you have installed the plugin already, please setting the static mapping. See https://github.com/shootaroo/jit-grunt#static-mappings

Warning: Task “express:dev” failed. Used—force, continuing.

Running “wait” task >> Waiting for server reload… Done waiting!

jit-grunt: Plugin for the “open” task not found. If you have installed the plugin already, please setting the static mapping. See https://github.com/shootaroo/jit-grunt#static-mappings

Warning: Task “open” failed. Used—force, continuing.

jit-grunt: Plugin for the “watch” task not found. If you have installed the plugin already, please setting the static mapping. See https://github.com/shootaroo/jit-grunt#static-mappings

Warning: Task “watch” failed. Used—force, continuing.

Done, but with warnings.

I tried to join localhost:9000 but not working

Hi, thanks for answer. I wrote you from ctapia@....

Edit: Is working.

I ask, the update is like (design, etc) the version you sent me in mail or like i downloaded here?

yo angular-fullstack:endpoint myTable -> Works fine!

yo angular-fullstack:route myTable -> Error! Error: Cannot find module ‘generator-ng-component/generators/route’ at Function.Module._resolveFilename (module.js:469:15) at Function.resolve (internal/module.js:27:19) at child.compose (C:\Users\Matias\AppData\Roaming\npm\node_modules\generator-angular-fullstack\generators\route\index.js:7:92) at Object.<anonymous> (C:\Users\Matias\AppData\Roaming\npm\node_modules\generator-angular-fullstack\node_modules\yeoman-generator\lib\base.js:439:23) at C:\Users\Matias\AppData\Roaming\npm\node_modules\generator-angular-fullstack\node_modules\yeoman-generator\node_modules\run-async\index.js:25:25 at C:\Users\Matias\AppData\Roaming\npm\node_modules\generator-angular-fullstack\node_modules\yeoman-generator\node_modules\run-async\index.js:24:19 at C:\Users\Matias\AppData\Roaming\npm\node_modules\generator-angular-fullstack\node_modules\yeoman-generator\lib\base.js:440:9 at runCallback (timers.js:637:20) at tryOnImmediate (timers.js:610:5) at processImmediate [as _immediateCallback] (timers.js:582:5)

teter

teter Purchased

Hi,.

If I’ll purchase mCRUD, I will able to modify the code anywere? Add features?, make changes in any part of the code?

I will satisfie the license terms.

Please confirm me!!!

Thanks in advance.

Yes teter you can do all those modifications

teter

teter Purchased

It’s posible to port your crud to an android app with cordova?

Hello Teter, It seems nodejs+npm installation is missing

npm i -g gulp-cli generator-angular-fullstack yo npm i -g—production windows-build-tools (Only for Windows) npm i gulp build

(mysql is config propertly)

Then, get dist folder and put into apache www, and doesn’t works, dist/client/index.html

What’s wrong?

I don’t think this will work with Apache.

i can’t see your demo&documentation website

Thanks Dex for informing. I will make it up soon.

Does your code support nested tables right out of the box? Meaning I have tables that depend details stored in other tables, which depend themselves on details on one or more tables related by one ore more foreign keys.

I imagine one should be able to CRUD each table and drilldown into the next level. Is that something that is very easy to implement using your code. Do you have ready examples?

Thank you.

I am sorry to say that the requested feature does not come out of the box. But you can always customize to have it.

Hi I purchased You’re CRUD and I get an error at RAN see attached doc thanks. npm WARN deprecated npmconf@2.1.2: this package has been reintegrated into npm and is now out of date with respect to npm /usr/local/bin/gulp -> /usr/local/lib/node_modules/gulp-cli/bin/gulp.js /usr/local/bin/yo -> /usr/local/lib/node_modules/yo/lib/cli.js /usr/local/bin/yo-complete -> /usr/local/lib/node_modules/yo/lib/completion/index.js

npm i -g gulp-cli generator-angular-fullstack yo

> yo@1.8.5 postinstall /usr/local/lib/node_modules/yo > yodoctor

Yeoman Doctor Running sanity checks on your system

✔ Global configuration file is valid ✔ NODE_PATH matches the npm root ✔ Node.js version ✔ No .bowerrc file in home directory ✔ No .yo-rc.json file in home directory ✔ npm version

Everything looks all right! /usr/local/lib ├── generator-angular-fullstack@4.1.2 ├── gulp-cli@1.2.2 └── yo@1.8.5 npm WARN lifecycle v8-debug@0.7.7preinstall: cannot run in wd %s %s (wd=%s) v8-debug@0.7.7 node -e ‘process.exit(0)’ /home/API/node_modules/.staging/v8-debug-44aef4fa npm WARN prefer global node-inspector@0.12.8 should be installed with -g

npm i

> v8-debug@0.7.7 install /home/API/node_modules/v8-debug > node-pre-gyp install—fallback-to-build

node-pre-gyp ERR! Tried to download(404): https://node-inspector.s3.amazonaws.com/debug/v0.7.7/node-v51-linux-x64.tar.gz node-pre-gyp ERR! Pre-built binaries not found for v8-debug@0.7.7 and node@7.4.0 (node-v51 ABI) (falling back to source compile with node-gyp) make: Entering directory `/home/API/node_modules/v8-debug/build’ CXX Release/obj.target/debug/src/debug.o ../src/debug.cc: In static member function ‘static Nan::NAN_METHOD_RETURN_TYPE nodex::Debug::Call(Nan::NAN_METHOD_ARGS_TYPE)’: ../src/debug.cc:38:27: error: no matching function for call to ‘v8::Debug::Call(v8::Local<v8::Function>&)’ v8::Debug::Call(fn); ^ ../src/debug.cc:38:27: note: candidate is: In file included from ../src/debug.cc:1:0: /root/.node-gyp/7.4.0/include/node/v8-debug.h:198:28: note: static v8::MaybeLocal<v8::Value> v8::Debug::Call(v8::Local<v8::Context>, v8::Local<v8::Function>, v8::Local<v8::Value>) static MaybeLocal<Value> Call(Local<Context> context, ^ /root/.node-gyp/7.4.0/include/node/v8-debug.h:198:28: note: candidate expects 3 arguments, 1 provided ../src/debug.cc: In static member function ‘static Nan::NAN_METHOD_RETURN_TYPE nodex::Debug::SendCommand(Nan::NAN_METHOD_ARGS_TYPE)’: ../src/debug.cc:46:61: error: no matching function for call to ‘v8::Debug::GetDebugContext()’ Isolate* debug_isolate = v8::Debug::GetDebugContext()->GetIsolate(); ^ ../src/debug.cc:46:61: note: candidate is: In file included from ../src/debug.cc:1:0: /root/.node-gyp/7.4.0/include/node/v8-debug.h:248:25: note: static v8::Local<v8::Context> v8::Debug::GetDebugContext(v8::Isolate) static Local<Context> GetDebugContext(Isolate isolate); ^ /root/.node-gyp/7.4.0/include/node/v8-debug.h:248:25: note: candidate expects 1 argument, 0 provided ../src/debug.cc: In static member function ‘static Nan::NAN_METHOD_RETURN_TYPE nodex::Debug::RunScript(Nan::NAN_METHOD_ARGS_TYPE)’: ../src/debug.cc:61:67: error: no matching function for call to ‘v8::Debug::GetDebugContext()’ Local<Context> debug_context = v8::Debug::GetDebugContext(); ^ ../src/debug.cc:61:67: note: candidate is: In file included from ../src/debug.cc:1:0: /root/.node-gyp/7.4.0/include/node/v8-debug.h:248:25: note: static v8::Local<v8::Context> v8::Debug::GetDebugContext(v8::Isolate) static Local<Context> GetDebugContext(Isolate isolate); ^ /root/.node-gyp/7.4.0/include/node/v8-debug.h:248:25: note: candidate expects 1 argument, 0 provided ../src/debug.cc:66:54: error: no matching function for call to ‘v8::Debug::GetDebugContext()’ debug_context = v8::Debug::GetDebugContext(); ^ ../src/debug.cc:66:54: note: candidate is: In file included from ../src/debug.cc:1:0: /root/.node-gyp/7.4.0/include/node/v8-debug.h:248:25: note: static v8::Local<v8::Context> v8::Debug::GetDebugContext(v8::Isolate) static Local<Context> GetDebugContext(Isolate isolate); ^ /root/.node-gyp/7.4.0/include/node/v8-debug.h:248:25: note: candidate expects 1 argument, 0 provided make: * [Release/obj.target/debug/src/debug.o] Error 1 make: Leaving directory `/home/API/node_modules/v8-debug/build’ gyp ERR! build error gyp ERR! stack Error: `make` failed with exit code: 2 gyp ERR! stack at ChildProcess.onExit (/home/API/node_modules/node-gyp/lib/build.js:276:23) gyp ERR! stack at emitTwo (events.js:106:13) gyp ERR! stack at ChildProcess.emit (events.js:191:7) gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:215:12) gyp ERR! System Linux 3.10.0-327.el7.x86_64 gyp ERR! command ”/usr/local/bin/node” ”/home/API/node_modules/node-gyp/bin/node-gyp.js” “build” “-fallback-to-build” “-module=/home/API/node_modules/v8-debug/build/debug/v0.7.7/node-v51-linux-x64/debug.node” “-module_name=debug” “-module_path=/home/API/node_modules/v8-debug/build/debug/v0.7.7/node-v51-linux-x64” gyp ERR! cwd /home/API/node_modules/v8-debug gyp ERR! node -v v7.4.0 gyp ERR! node-gyp -v v3.5.0 gyp ERR! not ok node-pre-gyp ERR! build error node-pre-gyp ERR! stack Error: Failed to execute ’/usr/local/bin/node /home/API/node_modules/node-gyp/bin/node-gyp.js build—fallback-to-build—module=/home/API/node_modules/v8-debug/build/debug/v0.7.7/node-v51-linux-x64/debug.node—module_name=debug—module_path=/home/API/node_modules/v8-debug/build/debug/v0.7.7/node-v51-linux-x64’ (1) node-pre-gyp ERR! stack at ChildProcess.<anonymous> (/home/API/node_modules/node-pre-gyp/lib/util/compile.js:83:29) node-pre-gyp ERR! stack at emitTwo (events.js:106:13) node-pre-gyp ERR! stack at ChildProcess.emit (events.js:191:7) node-pre-gyp ERR! stack at maybeClose (internal/child_process.js:885:16) node-pre-gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5) node-pre-gyp ERR! System Linux 3.10.0-327.el7.x86_64 node-pre-gyp ERR! command ”/usr/local/bin/node” ”/home/API/node_modules/.bin/node-pre-gyp” “install” “—fallback-to-build” node-pre-gyp ERR! cwd /home/API/node_modules/v8-debug node-pre-gyp ERR! node -v v7.4.0 node-pre-gyp ERR! node-pre-gyp -v v0.6.32 node-pre-gyp ERR! not ok Failed to execute ’/usr/local/bin/node /home/API/node_modules/node-gyp/bin/node-gyp.js build—fallback-to-build—module=/home/API/node_modules/v8-debug/build/debug/v0.7.7/node-v51-linux-x64/debug.node—module_name=debug—module_path=/home/API/node_modules/v8-debug/build/debug/v0.7.7/node-v51-linux-x64’ (1) crud-sql@2.0.1 /home/API ├── UNMET PEER DEPENDENCY angular@1.6.1 ├── UNMET PEER DEPENDENCY angular-animate@1.6.1 └── UNMET PEER DEPENDENCY angular-aria@1.6.1

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.0 (node_modules/chokidar/node_modules/fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.17: wanted {os“} (current: {os“}) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.0 (node_modules/stylint/node_modules/chokidar/node_modules/fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.17: wanted {os“} (current: {os“}) npm WARN angular-loading@1.1.0 requires a peer of angular@1.3.2 but none was installed. npm WARN angular-material@1.1.1 requires a peer of angular@>=1.3 <1.6 but none was installed. npm WARN angular-material@1.1.1 requires a peer of angular-animate@>=1.3 <1.6 but none was installed. npm WARN angular-material@1.1.1 requires a peer of angular-aria@>=1.3 <1.6 but none was installed. npm ERR! Linux 3.10.0-327.el7.x86_64 npm ERR! argv ”/usr/local/bin/node” ”/usr/local/bin/npm” “i” npm ERR! node v7.4.0 npm ERR! npm v4.1.2 npm ERR! code ELIFECYCLE

npm ERR! v8-debug@0.7.7 install: `node-pre-gyp install—fallback-to-build` npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the v8-debug@0.7.7 install script ‘node-pre-gyp install—fallback-to-build’. npm ERR! Make sure you have the latest version of node.js and npm installed. npm ERR! If you do, this is most likely a problem with the v8-debug package, npm ERR! not with npm itself. npm ERR! Tell the author that this fails on your system: npm ERR! node-pre-gyp install—fallback-to-build npm ERR! You can get information on how to open an issue for this project with: npm ERR! npm bugs v8-debug npm ERR! Or if that isn’t available, you can get their info via: npm ERR! npm owner ls v8-debug npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request: npm ERR! /home/API/npm-debug.log gulp serve [11:57:45] Requiring external module babel-register /home/API/gulpfile.babel.js:4 import _ from ‘lodash’; ^^^ SyntaxError: Unexpected token import at Object.exports.runInThisContext (vm.js:78:16) at Module._compile (module.js:543:28) at loader (/home/API/node_modules/babel-register/lib/node.js:144:5) at Object.require.extensions.(anonymous function) [as .js] (/home/API/node_modules/babel-register/lib/node.js:154:7) at Module.load (module.js:488:32) at tryModuleLoad (module.js:447:12) at Function.Module._load (module.js:439:3) at Module.require (module.js:498:17) at require (internal/module.js:20:19) at execute (/usr/local/lib/node_modules/gulp-cli/lib/versioned/3.7.0/index.js:24:18)

when i ran >>>>>>>> gulp serve 02:46:51] Requiring external module babel-register /home/API/gulpfile.babel.js:4 import _ from ‘lodash’; ^^^ SyntaxError: Unexpected token import at Object.exports.runInThisContext (vm.js:76:16) at Module._compile (module.js:528:28) at loader (/home/API/node_modules/babel-register/lib/node.js:144:5) at Object.require.extensions.(anonymous function) [as .js] (/home/API/node_modules/babel-register/lib/node.js:154:7) at Module.load (module.js:473:32) at tryModuleLoad (module.js:432:12) at Function.Module._load (module.js:424:3) at Module.require (module.js:483:17) at require (internal/module.js:20:19) at execute (/usr/local/lib/node_modules/gulp-cli/lib/versioned/3.7.0/index.js:24:18)

Hello Booza,

What I can see from the error is, its a nodegyp issue. Please follow the following instructions which should solve this

http://crud.codenx.com/doc/pre

i fix the error of the nodegyp :) now its a “SyntaxError: Unexpected token import” when running the “gulp serve”

your crud codnex domain is not working….

Can you get me html based document file? (offline available)

thanks.

Hello Dex,

Thanks for informing. Its up now.

Can you please tell me if there is a way this product can support Oracle DB?

Hello Mifthikar,

I have not tried Oracle but it should support oracle as its based on MySQL

by
by
by
by
by
by