Code

Discussion on Visual editor - A drupal 8.x page/block builder

drupalthemez

drupalthemez supports this item

Supported

48 comments found.

ayachi

ayachi Purchased

hello, visual editor don’t work with my config, i have “porto shop 7” drupal and all modules are update i upload the ‘libraries’ to the root and enable the modules but don’t work perhaps not compatible with ‘php code’ filter format ?

Hi,

Have you added gmap api key in visual editor configuration?

Hello,

I am having another issue, when ever an AJAX request execute the Visual Editor’s display hide out, below is the screenshot for reference: http://prntscr.com/l3l0rd

Hi,

Thank you for information, I will check the compatibility issue with paragraph fields and get back to you with updates.

Hello,

Is there any updates?

Hi, We have problem with Visual editor when using Internet Explorer + CKEditor. DropDown Styles and Format does not work well. Drop down does not open. The content of DropDown just flashes. So the change of Headings or Styles is not possible. In Chrome or in Firefox works all OK. Thanks for solution Lenka

Hi,

I will update you shortly on this.

Hi,

I am able to reproduce the issue and looking for solution. Meanwhile the workaround for this is to click Source button twice and then click drop down.

Hi, any upadte on our issue with IE and CKEditor? Our clients has to use IE :(, therfore we are really looking for fix… Thanks

Hello,

I requested a patch to remove character limit for heading component, after that you guys changed the Heading’s value from text field to text area.

I would like to have a WYSIWYG on that textarea. Please provide a patch for the above request.

Thanks

Hi,

I have updated the component. Please replace the content of HeadingComponent.php with content given in following link:

http://drupalthemez.com/patches/HeadingComponent.php.txt

It’s still coming up empty, http://prntscr.com/lqj2z9.

Quick patch would be appreciated, this issue has been opened since 26 days.

Hi,

I have update HeadingComponent.php at following link, please update content of HeadingComponent.php with it.

http://drupalthemez.com/patches/HeadingComponent.php.txt

Thanks for this module. Seems odd that the font_awesome folder needs to be copied from your module files to DRUPAL_ROOT/libraries/. But thanks for leaving that comment elsewhere in this comment thread – after copying the files to DRUPAL_ROOT/libraries/, it works now. Perhaps you should consider loading font_awesome from your module files?

Ok no worries :) Hey is there a way to place more columns inside a column? I guess, with how Bootstrap works, it would need to be a row inside that column, and then more columns inside the row.

As of now there is no option for nested grid. But I have planned for the same.

Ok. Thanks. Yeah, it would be a great feature. If you just copied all the features of the Divi plugin for Wordpress, your plugin would be incredible. It’s great, and it has a lot of potential :)

Hi Guys, is it possible to add predefined classes to your builder?

especially css classes

For components you can override twig templates to achieve the requirement.

I just did a clean drupal 8 install and keep having issues showing the page after creating it.

https://i.imgur.com/2MW0wLt.gifv

Drupal 8.6.10

Let me try and get back to you.

Hi,

I just tried using the same version of Drupal 8 and it is working fine. Can you check if there is any other module causing the error?

Or can you share a public url of the same at support@drupalthemez.com to check?

GLAMphoto

GLAMphoto Purchased

Hello, i have installed the visual editor in a clear drupal 8.2 site as it is shown in the installation manual. Also tried to a clear drupal 8.6.12 version. When i add a basic page, i can select the text format “visual editor”. The icon to start the visual editor appiers, but onclick nothing happens.

GLAMphoto

GLAMphoto Purchased

It is a strange problem, because on all iOs devices I can not open the visual editor in firefox (current version and later) . The current firefox version on pc (same settings as on mac) makes no problem and everything works fine.

In the further course of the browser console I have seen some messages with “content security policy”. Can this prevent the opening of the visual editor?

There are chances that some js files are getting blocked.

Also try removing js aggregation in drupal settings.

GLAMphoto

GLAMphoto Purchased

thanks for the quick support. I’ll try it

by
by
by
by
by
by