Code

Flutter UI Kit - GPS Tracking App

Flutter UI Kit - GPS Tracking App

Cart 70 sales
Recently Updated

Flutter is an open-source UI SDK created by Google. It is used to develop applications for Android and iOS from a single codebase. Flutter offers native performance, Flutter’s widgets incorporate all critical platform differences such as scrolling, navigation, icons and fonts to provide full native performance on both iOS and Android.

Gps Tracking UI Kit can be used for GPS tracker application in iOS and Android devices. It contains 41 screen with many function that can be used for GPS Tracking application or other application that just need some of design and function from this package.


Feature :

  • Compatible with Flutter 3.0.0
  • Use Null Safety
  • Clean, elegant & awesome design
  • Great animation
  • Great performance Android & iOS apps
  • Clean code with comments in all pages
  • Easy to customize code
  • Clean design
  • 40+ screen layout
  • Responsive design to all devices
  • Included with many function for maps and other such as custom marker with image and icon, history playback, image picker and cropper, beautiful shimmer loading, etc
  • Free Lifetime Updates & Customer Support

Download demo android here

v7.0.0 (May 17, 2022)
----------------------------------------------------------------------------------
- Compatible with Flutter 3
- Replace deprecated code regarding the Latest Flutter SDK (3.0.0)
- Update All Packages / Plugins to the latest version
- Replace package info with new package plugin that more stable & update
- Update code that using Crop Image Packages
v6.0.0 (February 16, 2022)
----------------------------------------------------------------------------------
- Compatible with Flutter 2.10.3
- Update email address used for example
v5.0.1 (January 13, 2022)
----------------------------------------------------------------------------------
- Bug Fixed on Android 12 (API 31)
v5.0.0 (January 05, 2022)
----------------------------------------------------------------------------------
- Compatible with Flutter 2.8
- Update Android targetSdkVersion to 31
- Upgrade Gradle version to support Android 12 (API 31) - Important *
- Sorting pubspec packages / plugins alphabetically
- Update All Packages / Plugins to the latest version
- Breaking Changes :
    - Pick Image (Compare the new code using getImage)
v4.0.0 (September 13, 2021)
----------------------------------------------------------------------------------
- Compatible with Flutter 2.5
    - Remove deprecated function (brightness & ThemeData accentColor) and change with the new function
- Replace geocode package with new package plugin that more stable
- Update some Packages / Plugins to the latest version
- Add Local Documentation about iOS Error when build on MacOS #2
v3.0.0 (April 16, 2021)
----------------------------------------------------------------------------------
- Major Change - Migrate Flutter UI Kit - GPS Tracking App to Null Safety
- Upgrade all package and plugin to use Null Safety
- Update to better documentation file
- Remove changelog.txt and move it to documentation
v2.0.0 (March 17, 2021)
----------------------------------------------------------------------------------
- Support Latest Flutter SDK (2.x.x)
- Major change
    - Replace deprecated code regarding latest Flutter SDK such as List, FlatButton, RaisedButton, OutlineButton, etc
v1.1.0 (Oktober 16, 2020)
----------------------------------------------------------------------------------
- Update GPS Model and historyGpsData
- Added Device Command History Model
- Added Device Model and Data
- Added Geofence Model and Data
- Added Notification Model and Data
- Change How To Store and Use Data using Model (MapAllDevices, HistoryMap, Geofence, SetDevice, Notification, DeviceCommandHistory)
v1.0.0 (September 1, 2020)
----------------------------------------------------------------------------------
- Initial Released


Contact us here



Free Lifetime Updates & Great Customer Services
We will make updates to add features in the future to make this ui kit more perfect. If there is an update from the Flutter SDK, we will also perform updates to improve performance quality.



More Product


by
by
by
by
by
by

Tell us what you think!

We'd like to ask you a few questions to help improve CodeCanyon.

Sure, take me to the survey