eggemplo

eggemplo supports this item

Supported

This author's response time can be up to 1 business day.

94 comments found.

Me está dando un problema tras la actualización a la versión 2. En la plataforma de Redsys me muestra el mensaje: Error en datos enviados. Contacte con su comercio.

Hola zigmas,
para preguntas sobre soporte por favor usa el sistema de comentarios de la página del plugin, estamos intentando dejar este canal para preguntas pre-compra. Recuerda que si cambias a sha256, debes actualizar tambien la clave de cifrado. En este artículo tienes cómo obtenerla.
Saludos,
Antonio B.

Hola, el plugin es compatible con el plugin Woocommerce Suscriptions 2.X? Gracias

Hola,
no, lo siento, no es compatible con Woocommerce Subscriptions.
saludos

Completado para productos descargables. Hola necesito un plugin para Redsys, pero que tenga la opción de pasar al estado completado cuando el producto sea descargable y cuando no lo sea a procesando. Este plugin soporta esta característica, muchas gracias por su atención.

Hola,
si, el plugin notifica a Woocommerce que el pago se ha realizado correctamente. Y Woocommerce por defecto actualiza los pedidos de productos digitales a ‘Completado’, y los no digitales a ‘Procesando’.
Saludos,
Antonio B.

Hola , tengo un problema , acavo de actualizar la firma a SHA256 , em modo prueba funcciona bien , pero en entorno real me da error de datos enviados y en el aviso de la tpv en el importe pone esto “Importe 0 Sin Asignar” .

He desactivado el plugin “All in one SEO” y he actualizado woocomerce y wordpreess , antes de la actualizacion y despues pasa lo mismo .

Hola sibisan,
¿has actualizado los datos de configuración para el nuevo entorno real? Me refiero a ‘numero de comercio’, ‘num. terminal’, ‘clave’, etc …
Por favor, para preguntas sobre soporte usa el sistema de comentarios de la web: http://www.eggemplo.com/es/blog-es/woocommerce-servired-payment-gateway/
Saludos,
Antonio B.

Hola, el plugin da fallo de datos enviados… contacte con su comercio…

Hola,
ese fallo suele ser problema con los datos introducidos en la configuración. Revisa que tiene los datos correctos y que corresponden con el entorno real o de prueba seleccionado.
Si el problema persiste, puedes enviarme un email a info@eggemplo.com con los datos de acceso a la web y puedo revisar tu configuracióin.
Saludos,
Antonio B.

Buenas, tengo el siguiente error: https://www.miweb.com/?wc-api=WC_Gateway_Servired Server returned HTTP response code: 403 for URL: https://www.miweb.com/?wc-api=WC_Gateway_Servired

Parece que hay conflicto con plugin de seguridad iTheme Security y no se como arreglarlo sin tener que desinstalar el plugin de iTheme, se podría??? gracias y un saludo

Para el que le pase lo mismo he encontrado la solución en este link:

http://servisplus.es/plugins-wordpress/error-1-server-returned-http-response-code-403-for-url/#comment-5908

Hay que desactivar las opciones de Banned users -> HackRepair.com’s blacklist feature de iThemes

Además en algunos casos en System Tweaks los parámetros de: Suspicious Query Strings y Filter Long URL Strings, también han de ser desactivados para que el retorno del pago desde la pasarela no de problemas ya que se generan cadenas de querys con caracteres y URLs muy largas.

Saludos

Perfecto, muchas gracias por el aporte !!
Saludos

hola,

necesito habilitar el pago con tarjeta solo para España, no a la resta de paises que estaríamos vendiendo también. Creo que no existe la opción con este plugin y con woocommerce directamente, pero tendría solución rápida adjuntando un codigo ? podrías indicarme cuál ? gracias !

Hola noe_sp,
No lo he probado, pero quizás este plugin te ayude: https://es.wordpress.org/plugins/woocommerce-country-based-payments/
Saludos,
Antonio B.

Fantástico ! muchas gracias !!

un saludo

Tengo la última versión de este plugin, pero cuando intentamos realizar el pago da el siguiente error

Fatal error: Cannot redeclare class Services_JSON in /homepages/15/d546597231/htdocs/shop/wp-content/plugins/woocommerce-servired/apiRedsys/json.php on line 116

La versión de WP es la más reciente 4.6.1 y la de woocommerce 2.6.8

Muchas gracias

Hi,
ese error suele aparecer cuando tienen instalado el plugin que ofrece Servired para woocommerce. Si lo eliminas, deberías poder usar nuestro plugin.
Saludos,
Antonio B.

Dudas pre-compra

Hola,

Me gustaría confirmar los siguientes puntos: - actualmente funciona con banco sabadell, - redirige automáticamente a la pasarela de pago sin añadir una pantalla más en el proceso de compra

Saludos,

Xavier

Hola Xavier,
Si, Banco Sabadell aparece entre las entidades bancarias que usan redsys: http://www.redsys.es/quienes-somos.html
Cuando el usuario elige pagar con tarjeta en el último paso del carro de compra, aparece una nueva página indicando que ha elegido pagar con tarjeta, pero automáticamente (el usuario no tiene que hacer nada) redirige a la página oficial del banco.
Saludos,
Antonio B.

Muchas gracias! Me podrías pasar un enlace para ver exactamente el proceso?

Saludos,

Xavier Pérez

Buenas,
mándame un email a info@eggemplo.com y te paso una versión de pruebas.
Saludos

Hola buenas.

Tengo dos preguntas:

1) El plugin oficial tiene un problema y es que si en la ventana del TPV el cliente vuelve atrás o recarga, el TPV le da fallo por pedido duplicado. ¿Este plugin solventa eso?

2) Estoy con webempresa, y por cómo está configurado ahí el server compartido el plugin tiene que funcionar con SNI. Entiendo que simplemente indicándole al plugin que funcione con HTTP ya debería conectarse aunque la web esté con un SSL SNI y debería confirmar los pagos. ¿Es así? ¿Necesito hacer algo más?

Muchas gracias y saludos. Jose

El SSL que me recomiendan es el gratuito de Let’s Encrypt, por si tiene algo que ver.

Hola,
1.- No nos han reportado ese error, por lo que no debería ocurrir.
2.- Con la versión actual 2.1 puedes forzar que la respuesta sea sobre http, por lo que se elimina el error con ciertos certificados digitales que Servired ‘rechaza’.
Si quieres puedes enviarme un email a info@eggemplo.com y te mando una versión de pruebas que puedas testear antes de comprar.
Saludos,
Antonio B.

He instalado el Plugin, cuando voy a realizar un pago en mi tienda pone lo siguiente: Gracias por su pedido, haga click en el botón para proceder al pago.

Sin embargo, no aparece ningún botón.

Hola Borja,
esa es una pantalla intermedia que debería salir de ella automáticamente. Quizás tengas algún otro problema javascript que hace que el salto no se realice.
Si me puedes indicar la web, le echo un vistazo (si no quieres ponerla aqui públicamente, puedes enviarme un email a info@eggemplo.com)
Saludos,
Antonio B.

Hola, ¿ el plugin se salta el paso intermedio que sale otro botón que pone pagar con tarjeta? Es decir una vez pulsas realizar el pedido, ¿va directamente a la zona donde introducir el número de la tarjeta? Una vez pagado marca el pedido como completado? Gracias.

Hola @fliper,
No, esa pantalla sale, pero es redireccionada automáticamente tras 1 segundo a la pasarela de pago del banco. Referente al estado, sí, el pedido es actualizado cuando el pago es realizado.
Saludos,
Antonio B.

Hola me gustaría saber si este plugin funciona cuando tienes habilitado cloudflare y ssl, también si me puedes confirmar por favor que los pedidos pagados correctamente se marcan como completados no como procesando. Gracias

Hola gracias por tu respuesta te contactara mi compañero para que le pases el plugin de prueba, aun así he visto en otro plugin la opción marcar siempre como completado sea cual sea el tipo de producto. Por favor puedes confirmar si esa opción esta o no disponible en el tuyo?. Gracias

http://i.imgur.com/G6tBzdS.png

Hola,
No, esa opción no está disponible.
<Saludos

Antonio, hace tiempo que hemos estado usando este plugin sin problema alguno, merece mucho la pena simplemente para ahorrarse la integración manual de Redsys. Sin embargo, hace unos días actualizamos la versión de PHP de nuestro hosting a 7.0 y hoy hemos detectado algunos errores generados por el archivo json.php. Hemos contactado con redsys pero todavía no hemos obtenido respuesta, después de mirarlo hemos visto que cambiando el nombre de las funciones Services_JSON y Services_JSON_Error por __construct solucionamos el problema. No sé si te será de ayuda, gracias y saludos!

Hola,
Muchas gracias por el aporte, lo voy a revisar.
Un saludo,
Antonio B.

by
by
by
by
by
by