CodeCanyon

WooCommerce Product Configurator

WooCommerce Product Configurator

Iconic on Facebook Iconic on Twitter Iconic on Envato

The WooCommerce Product Configurator plugin is a fantastic addition to your WooCommerce store. Let’s set the scene:

You sell variable products that the user can configure, let’s say sunglasses. The user can choose a colour for the main frame, left arm, right arm, and a lens type. There are 3 different lens types and 4 different colours for the other attributes. This makes a total of 192 possible variations. It would be a terrible job making 192 different variation images for your customer to see, and what happens when you want to add a new attribute into the mix?

This is where the WooCommerce Product Configurator comes in. Using transparent PNGs, you can assign an image to each attribute value of you product. These are then combined into a single final image, based on your customer’s selection. This means you only need to create 15 images. On top of that, adding a new attribute or attribute value is simple!

So if you sell variable products and want your customer to see what they’re buying, without you having to create an extortionate number images, the WooCommerce Product Configurator plugin is for you!

Changelog

**v1.2.0** (02/04/2017)  
[update] Compatibility with WooCommerce 3.0.0  
[update] Add static layer functionality  
[update] Remove redux and add settings framework  
[update] Tidy code and comments  
[fix] Fix issue with sorting layers  
[fix] Issue with uploading media to attribute  
[fix] Use WC ajax URL  
[fix] Compiled image in order emails  
[fix] Issue with product specific atts not loading layer on load  
[fix] Issue loading query selected layer with spaces

**v1.1.5** (22/12/2016)  
[fix] Some updates regarding image generation were missing  
[update] Envato market updater  
[update] Add filter to order email thumbnail  

**v1.1.4** (27/04/16)  
[update] Author tags  
[fix] Check to see if WooCommerce is active - fix issue on multisites  
[fix] Some hosts don't allow remote images in getimagesize, changed to path so images are generated  
[fix] Error when no default image is set, but it was before  
[fix] Make sure correct image shows in email if it's enabled  
[update] Add validation to check for PNG images  
[fix] Attribute add default image button

**v1.1.3** (16/01/16)  
[fix] admin_url SSL issue
by
by
by
by
by
by