dtbaker

dtbaker does not currently provide support for this item.

34 comments found.

Hi, Is it possible to show only International Air? Because we do not do other delivery service. Cheers.

Yep in the settings area you should be able to untick all the other options except International Air

Hi, but where it is. I have gone through the whole site. I could not find it.

Hi, Any updates on shipping methods? I want to show only International Air. The setting is not at “WooCommerce > Settings > Shipping > New Zealand Post”. I could not find it anywhere.

Hello,

Please go to Plugins > Editor

Select WooCommerce NZ Post from the plugin dropdown on the right.

Select the nzpost.php file

Scroll down to about line 66 where you see this code:

$rate = array(
            'id'         => 'new_zealand_post'.$group,
            'label'     => $group,
            'cost'         => $cost,
            //'taxes'     => $tax,
            'calc_tax'     => 'per_item', // not sure here?
        );

change it to this code

if(strpos($group,'International Air') === false)return;
$rate = array(
            'id'         => 'new_zealand_post'.$group,
            'label'     => $group,
            'cost'         => $cost,
            //'taxes'     => $tax,
            'calc_tax'     => 'per_item', // not sure here?
        );

And press save.

Hi – is this still being updated? Or shall I just go for the woocommerce official plugin http://www.woothemes.com/products/new-zealand-post/ ?

The demo on here is broken and the version is out of date.

Just asking – thanks.

Yes the demo seems off line at the moment. Which part is out of date?

You’re welcome to go with the other one but some say it doesn’t work.

I should be able to sort out the demo here when back in the office on Monday.

Thanks, dtbaker

Does this work with woocommerce 2.1.2 (latest version) – i don’t care too much about the demo, I was just letting you know ;-)

Is this compatible with latest woocommerce 2.1.2 and latest Wordpress 3.81 ? What is the support available ?

Thanks

Would it be accurate to assume this plugin is no longer under development? I see there are unanswered compatibility questions dating back 9 months ago.

Is it compatible with WP 4.0.1 and Woo v2.2.8 ?

Cheers…

I should be back on deck next week and can do a proper test.

Thanks for the prompt reply. I look forward to seeing news on this soon. Regards…

Hi, just updated to the latest version of Woocommerce and got a white screen of death with this error when trying to going to checkout:

Strict Standards: Declaration of new_zealand_post::is_available() should be compatible with WC_Shipping_Method::is_available($package) in /www/wp-content/plugins/nzpostwoocommerce/nzpost.php on line 0

Any idea how to resolve this? Cheers

Obviously not compatible with latest wordpress and woocommerce. Since our site update get fatal error on cart page.

/wp-content/plugins/nzpostwoocommerce/nzpost.php on line 492

paid for priority support and nothing ….. as yet. same deal as printnet will not work with latest wordpress/woocommerce

Go to downloads page, click download, choose installable WordPress file option

Hi there,

the plugin is showing a fatal error for me:

PHP Fatal error: Call to undefined method WooCommerce::show_messages() in /home/health/public_html/wp-content/plugins/nzpostwoocommerce/nzpost.php on line 492

How can I resolve this?

Kind regards, Tim

This has not been updated for a long time, will it still work on the most up to date Wordpress and Woocommerce?

Hey there, it probably won’t work sorry. Hopefully we get time to test and fix anything in the coming weeks.

Would love to have this available

Hello. Is this plugin still current? Does it work with the latest WC and WP? Looks like it has not been updated in a long time, so thought I should ask.

Also, does it use the newer 2.0 version of the NZ Post ShippingOptions API, or is it still using the depreciated v1.0 API?

No sorry it isn’t quite current, we’re still finding time to update it to ensure it all works.

Request: Can you make this plugin relevant with necessary update. I love this plugin.

by
by
by
by
by
by