storeapps

storeapps supports this item

Supported

30 comments found.

Getting this in debug.log. can you please to an update for this?

13-May-2016 09:48:58 UTC] PHP Warning: Illegal string offset ‘address’ in …/wp-content/plugins/woocommerce-coupons-by-location/classes/class-coupons-by-location.php on line 254

[13-May-2016 09:48:55 UTC] PHP Warning: Illegal string offset ‘address’ in /wp-content/plugins/woocommerce-coupons-by-location/classes/class-coupons-by-location.php on line 254

Still getting this failure – really need a fix urgent – Warning: Illegal string offset ‘address’ in /wp-content/plugins/woocommerce-coupons-by-location/classes/class-coupons-by-location.php on line 254

Sorry about the problem. We have a fix for this coming in the next release – due in a day or two.

I just update the plugin to the latest version. According to your changelog, the newest version is 1.2.6 however the plugin in my WP dashboard shows as version 1.2.34. Please clarify why the version numbers don’t match and if I’m really running the newest version. Thank you very much.

Be aware that your installable WordPress file is the one I downloaded and installed. It is showing as version 1.2.34 (which you said is actually 1.2.4). I also just checked the download that includes the documentation and that shows correctly as version 1.2.6. Please update the installable WordPress file so that it is the latest version 1.2.6. Thank you.

Thank you for informing. We are in communication with CodeCanyon team for this. Can you please confirm that you’ve downloaded it from your account at CodeCanyon. Because when I’m downloading it from my account it is giving correct file i.e. version 1.2.6

Yes, I downloaded the installable WordPress file from my CodeCanyon account.

I have the same problem as the person above. I’ve just downloaded the plugin. But is says 1.2.34 in stead of 1.2.6. Also it seems not to work for 2.6. Before (Woocommerce 2.5.5) it always worked just fine

Hi, I am sorry, you are right. Nevertheless I have problems with your plugin too sinds 2.6.1;-(

When I activate the plugin the coupon codes with a postal code in it don’t work.

I found some one to fix this for me.

Great to know that you got the issue fixed. Would you like to share the fix with us. We’ll include it in the plugin, which will help others as well.

Hey,

Is there a way to apply the coupon automatically, if a customer is in a specified region?

Currently this is not possible. But it’s an excellent idea. We will put it on our list for future development. Thanks.

Hello there- I’m very interested in buying this. Does it work across the world? I will buy it if I am able to restrict to the city of Abu Dhabi in the UAE. Many thanks.

Yes, you can restrict coupon to city. But you’ll have to type city name such that it’ll match with the city entered by customer. For example, if you want to restrict it to Abu Dhabi, then restrict it to Abu Dhabi or AbuDhabi or Abu-Dhabi & so on…

Will this work for Military use? Offer auto coupon if APO or FPO address is used by customer? Thanks!

It’s interesting! Currently it’s not supported. But to add this kind of support we would like to know how WooCommerce is accepting this kind of address & in which all fields on checkout page.

is there an easy way to enter in a long string of zip codes? when i try, it creates one large entry. maybe i’m using the wrong separator?

we need to enter in about 100 zip codes to 3 different coupons. this is going to be very tedious if we have to do each one manually… so I’m truly hoping that you guys have a solution for this one!

Currently we don’t have any solution for this, but we’ll be adding this support in future.

We’ve added this feature & it’ll be available from next version (1.2.7) onward

Hi i have a pre-sales question i have latest wp 4.7.3 woocommerce 3.0.2 on php 7.1 is your plugin compatible?

thanks

Currently It’s not compatible with WooCommerce 3.0+ but we are in process of making all our plugins compatible with WooCommerce.

You can track progress of compatibility here: http://www.storeapps.org/latest-woocommerce-compatibility-made-easy/

Soon all plugins will be updated.

Compatibility with WordPress & PHP should not be a problem. Plugin should work perfectly on PHP 7.

fox-didl

fox-didl Purchased

Getting this error with WooCommerce 3: Warning: call_user_func() expects parameter 1 to be a valid callback, class ‘SA_WC_Compatibility_2_6’ does not have a method ‘is_wc_gte_23’ in /.../wp-content/plugins/woocommerce-coupons-by-location/classes/class-coupons-by-location.php on line 64

It seems that you are using version 1.2.6 or earlier (it’s not compatible with WooCommerce 3.0.0+)

Please download latest copy (version 1.2.7) from your account.

by
by
by
by
by
by