RightPress

RightPress supports this item

Supported

685 comments found.

egmGroup

egmGroup Purchased

It seems like the last version isn’t compatible with the new woocommerce. No e-commerce tracking is happening. Could you confirm this?

Hi!

We’re not aware of any issues with the new WooCommerce versions. Are you using latest WooChimp 2.2.4 version? Please submit a support ticket to us with temporary login credentials, so we could look into your setup.

Kirill

Im interested in buying this plugin but I read allot of this is not ready this will be in the next update. But no real promises when this update will come, while last update was a year ago. Any eta on the update?

Hi!

Unfortunately, no ETA so far. We do understand there are various issues to be solved, and some new features to add, and we’d be glad to do that as soon as possible.

Kirill

Is the plugin safe to use with EU GDPR?

Hi!

Currently it doesn’t yet support all of the features, but we will provide the update in the nearest time.

Kirill

Would love for this to be GDPR compliant as well. Thanks! :grin:

Hi!

Sure, we’ll do what we can. Thank you for your support! :)

Kirill

Any idea in which timeframe the plugin will be GDPR compliant. We have been waiting for an update for almost a year now.

by
by
by
by
by
by