Code

Discussion on WPBakery Page Builder for WordPress

Discussion on WPBakery Page Builder for WordPress

4.64 (10,854 ratings) 4.64 stars
Cart 398,305 sales
Recently Updated

wpbakery supports this item

Supported

This author's response time can be up to 1 business day.

2607 comments found.

Hi there!

I’m currently running the latest version of the plugin on Wordpress, and am trying to adjust Role Manager settings (specifically, I’m trying to remove the checkbox from Disable Classic editor).

Once I click on “Save Changes” the following message appears: “Roles settings successfully saved.”

However, after refereeing the page, the settings revert back to those before any changes were made.

How can I fix this?

Thank you, -K

Hey,

I made a little plugin which will allow the CSS animations to trigger whenever the item becomes visible on the page as I’ve had many request for this. Not sure if you wanted to take a look:

Might be nice to have this functionality available in the plugin by default (maybe an on/off switch in the WPBakery General Settings).

If you aren’t planning on adding the functionality to core I’ll upload the plugin to WP.org so others can benefit ;)

Have a nice weekend!

- AJ

Hi, I’ve purchased a theme with WPBakery Page Builder bundled and I believe I’ve found a bug which I’d like to report. I’ve been told it is not theme related, but plugin related instead.

If I open a front-end editor of a Post or a Page, the editor loads but I am unable to scroll the page at all (I am locked in position within initial viewport). After checking the console, this error is present: Failed to load resource: the server responded with a status of 404 () /wp-includes/wp-includes/js/jquery/ui/core.min.js?ver=6.4.1

If I check the files, the core.min.js actually is there, but not the 6.4.1 version. The file in wp-includes is 1.11.4.

However, I’ve noticed the duplicated “wp-includes” folder in that path, which could be the issue.

I’ve also noticed the 6.4.1 is the version of WP Bakery. I’ve tried updating it to version 6.6 but no luck, the same error except now it is trying to load the core.min.js with version number of 6.6.

I believe this JS error is preventing the scroll from working, making the front-end editor unusable.

Thank you very much.

Hello, It looks like a conflict arising from third party plugin/theme used at your end. Can you check the same at your end by deactivating rest of the plugins and using a default theme like twenty twenty one?



Knowledge Base · Official Support · Facebook · Twitter

Don’t forget to join our newsletter. Be first to get news and inside secrets from WPBakery team.

Is equal columns (for height) still an option? I don’t see it anymore in the Row settings or columns settings

Hello, There can be an issue if the option is disabled by the theme or a plugin used at your end.



Knowledge Base · Official Support · Facebook · Twitter

Don’t forget to join our newsletter. Be first to get news and inside secrets from WPBakery team.

Hello, the default heading of title in Accordion is H4 Can u help me, how to change it to H3 or paragraph? Thanks David

Does WPB have support for using it with custom wp_editor instances? Or can we create a custom instance of WPB to use it on a custom element within a theme?

Hello, The WPBakery Page Builder can work with default WordPress editor area. Unfortunately, it cannot be used on custom instances of wp_editor.



Knowledge Base · Official Support · Facebook · Twitter

Don’t forget to join our newsletter. Be first to get news and inside secrets from WPBakery team.

Palda

Palda Purchased

Hi, checking for updates on this address: http://updates.wpbakery.com/ take up to 10 seconds. 1. How can I change to https 2. or can I disable it, as I don´t need use it.

Thanks

Hello, how do I activate WPBakery on theme thelma. I cannot find the place to add the license key

Hello, There can be an issue if the product license tab is disabled by the theme. In this case, you can contact the theme developer and get rid of the code used to disable the product license to get it back. Once done, you can then activate the plugin license as per: https://wpbakery.com/video-academy/activate-wpbakery-page-builder-wordpress-license/



Knowledge Base · Official Support · Facebook · Twitter

Don’t forget to join our newsletter. Be first to get news and inside secrets from WPBakery team.

Hi, I bought your plugin a few years ago. I installed it on a site and lately the editor was no longer working. Now though, I have installed the latest version 6.60 on a new website and I can’t edit the pages. I have switched the old license to this new site. When I click on the edit button, it loads endlessly. I haven’t renewed my support, do I need to do it to fix this? Thanks

I solved by disabling this plugin: All In One Addons for WPBakery Page Builder (formerly Visual Composer).

Hi,

I updated the plugin and now it does not work properly. :(

I get this message: “you have an outdated version of WPBakery Page Builder Design Options. It is required to review and save it.” But When I click in “Open Design Options” appears another message saying that I don’t have permission to enter this page… I read lots of FAQS and done a lot of web research and I cannot find the solution. :(

Can you help me please?

Thank you so much.

Liliana

Hello, It looks like the design options at your end are disabled. You can follow these steps: 1) switch onto a default theme like twenty nineteen. 2) go to WPBakery Page Builder -> design options -> disable or re-build & save. 3) switch back to the main theme.



Knowledge Base · Official Support · Facebook · Twitter

Don’t forget to join our newsletter. Be first to get news and inside secrets from WPBakery team.

Hi, is there a way to set the content of the expandable section aligned to the left and not to the center? THanks

Hello, The expandable section is not our standard element. The plugin has element such as accordion whose content is left aligned by default.



Knowledge Base · Official Support · Facebook · Twitter

Don’t forget to join our newsletter. Be first to get news and inside secrets from WPBakery team.

Hi,

We reported this problem 4 months ago, you released new plugin updates but haven’t included this very small fix but with a big impact.

When you are on the Insert/edit link area and clicks the “Open link in a new tab” WPBakery doesn’t automatically add the rel=”noopener when there are links target=”_blank” there.

(view large version)

In Lighthouse I get a recommendation of Links to cross-origin destinations are unsafe.

Add rel=”noopener” to any external links to improve performance and prevent security vulnerabilities.

New tab links should look like this example:
<a href="https://mysite.com" target="_blank" rel="noopener">My Site</a>

You can read more on this link: Links to cross-origin destinations are unsafe.

This is very important standard and I hope that you will add this by default as soon as possible so our sites will be more secure and have a better score on Lightroom too.

Have a nice day!

Best Regards,
Ylli from Laborator

Wordfence is giving this warning after scanning on a client’s site (yes, the most recent version of the plugin is being used). Please help!:

[MAR 22 12:12:23]

Warning: Creating default object from empty value in /public_html/wp-content/plugins/js_composer/include/classes/updaters/class-vc-updating-manager.php on line 128

Notice: Undefined property: stdClass::$sections in /public_html/wp-content/plugins/js_composer/include/classes/updaters/class-vc-updating-manager.php on line 129

Notice: Undefined index: changelog in /public_html/wp-content/plugins/js_composer/include/classes/updaters/class-vc-updating-manager.php on line 130

stpstp Purchased

Hello!

Is there a way to apply the Post Grid animations to Masonry Grid or at least remove the default animation? I see options but they’re None, Fade in and default and nothing changes.

The Masonry grid items always wait a few seconds then fly-in from the bottom left. Its really annoying. :(

Hi guys,

Hope you can assist,

I’m trying to disable the builder on specific custom post types via Role manager > Admin. But when I uncheck my cpt and save, they just reload as being checked again.

Thanks

Hi there,

Thanks for the response, I’ve tried this with an up to date version and with all plugins disabled and it’s still not working.

Thanks

Hi,

I just wanted to address an improvement that you can easily add on the next version of WPBakery Page Builder.

When you are on the Insert/edit link area and clicks the “Open link in a new tab” WPBakery doesn’t automatically add the rel=”noopener when there are links target=”_blank” there.

(view on a new page)

In Lighthouse I get a recommendation of Links to cross-origin destinations are unsafe.

Add rel=”noopener” to any external links to improve performance and prevent security vulnerabilities.

New tab links should look like this example:

<a href="https://mysite.com" target="_blank" rel="noopener">My Site</a>

You can read more on this link: Links to cross-origin destinations are unsafe.

This is very important standard and I hope that you will add this by default as soon as possible so our sites will be more secure and have a better score on Lightroom too.

Have a nice day!

Best Regards, Ylli from Laborator

BRUJULA

BRUJULA Purchased

Hello, I don’t see the “Design Options” menu, how can I activate it?

Hello, It might be disabled by the theme using an integration code. In such case, you can contact theme developer to re-enable it.



Knowledge Base · Official Support · Facebook · Twitter

Don’t forget to join our newsletter. Be first to get news and inside secrets from WPBakery team.

Updated to the latest version (bot Wordpress and theme), but the toggle module doesn’t work on the front end without the jquery migration plugin. When I load the page it shows up for a fraction of a second and then disappears. Everything else seems to work fine. Any idea on how to fix it?

Hello, Please check it at your end by deactivating rest of the plugins and using default theme to make sure none is conflicting with toggle output.



Knowledge Base · Official Support · Facebook · Twitter

Don’t forget to join our newsletter. Be first to get news and inside secrets from WPBakery team.

After updating to WordPress 5.6.2 the backend/frontend visual editor is not working anymore. I am using Version 6.6.0 of WPBakery page builder with Gutenburg disabled.

I no longer have support, but wanted to report a bug. Couldn’t find a way to do it one your site.

I have a row with 3 columns, and the row is set to stretch row with a solid background color so the background goes from edge of browser to the other edge with content centered. It displays fine on first load, but resizing the browser cause the row layout to shift or rather expand to the right edge. It appears that javascript is adjusting the rows left margin negative while adding the same amount of padding to the left. However the right padding is set to zero, causing the row to expand to the far right edge of the browser. If I add use developer tools to add that same right padding, the content appears centered as it should.

The only other plugin that I have that interacts with composer is the Ultimate Addons for WPBakery Page Builder. I still have the problem when it is disabled.

by
by
by
by
by
by