Discussion on Visual Composer Add-on Image Hotspot with Tooltip

sike

sike supports this item

Supported

199 comments found.

Hi, I would like to know how I can remove the hotspot dot completely, The image i’m hotspotting has circles already and don’t need another set atop of it.

Thank You Reza

Hi. Is there any way to make the marker completely hidden or transparent?

Hi, you can try to customize the CSS in the style.css or add custom CSS in the page to make it transparent.
Regards

Hi, does the theme have to have Visual Composer to use this plugin? I know it was built for VC, but does that mean that without VC it can’t be used? Thanks.

Hi, this is add-on for VC, so the VC is require installed in the theme.
Regards

Hi, Is it possible to add one or more hotspots to a modal window image? So for example… I have a number of thumbnails on my page. If you click a thumbnail it would load a modal window with the larger image. Is it possible to hotspot this larger image in the modal window? Many thanks, Jamie

Hi, the hotspot popup content support basic, so you can embed a image inside it. You can add the image via something like:
<img src="path/to/the/image.jpg" alt="" />
Regards

Is it possible to define a rectangle area that displays the modal window? I need a plugin for visual composer that can highlight rooms from a building plan to display details of that room. Something similar like this site: http://www.palais-schoenburg.at/de/rooms

Is this possible with your plugin?

Hi it looks like there is some js error in the page, I can’t see the popup. The content in this add-on support basic HTML, you can embed image or video etc, as show in the demo.
Regards

hi how i can reduced the hotspot size? because on table and mobile the hotspot are very large….

thanks so much

Hi, thanks your feedback, the icon size is fixed now. Will make it more responsive in the future update.
Regards

YoloPSD

YoloPSD Purchased

Hi. I have issue with PHP 7. “Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; VC_Extensions_HotSpot has a deprecated constructor in xxx/wp-content/plugins/vc-extensions-hotspot/vc-extensions-hotspot.php on line 12” How can I fix this issue? Thanks

Hi, thanks your feedback, will update to be compatible with PHP7, you can drop me a line via the contact form in my profile page, then I can send you the update immediately.
Regards

Hi there! We are using your extension in a site we developing right now and i was wondering is there a way to add different class for each hotspot dot?

Thank you in advance.

Hi right now it doesn’t support this. You have to customize the code to add it.
Regards

How to keep the tool tip visible by default?

Thanks

Hi, while uploading plugin it tells me this:

Unpacking the package…

Installing the plugin…

The package could not be installed. No valid plugins were found.

Plugin install failed.

This can’t be right, can it?

Pls let me know – thanks!

Hi, please try to unzip the file first, the installable zip plugin file is inside it.
Regards

Hello Sike! Thank you for this new update! :)

Hi. Can you let us know how to make the size of the hotspot larger? Last comment on here in regards to this was a year ago and your reply stated that there are plans to implement more variations for this. Have you been able to implement that?

If not, can you please provide me with the CSS classes that handle each element?

Thank you.

Hi thanks your feedback, right now there is no schedule for the update. It not only change the CSS, required to update js/php code at the same time to make the hotspot size more variable.
Regards

HI I have bought this and currently using it on this link: http://garibaldina-estate.com/map-full-page/

It works great on Chrome, firefox and Edge but it does not show up on IE.

Can you help?

Thanks!

Hi, I can’t see any error feedback in the page with IE, but a blank large space below the image.
Regards

I am having the following issues:

1. tool tips never stay the color or style i select 2. i can’t move the tool tips as advertised 3. i can’t add any tool tips either. 4. every time i try to adjust anything, all my links immediately disable

can someone please contact me on these issues?

thanks, whitney whitney@ftkmemphis.com

Hi, please try to update this plugin to the latest version first. And you can send me the page and WP account via the contact form in my profile page too, then I can try to help.
Regards

I’m running the 1.5 version, what is the best way to update it without losing the settings and contents for it? As there is no auto-update option for it.

Thank you for that. Shall I just uninstall and reinstall with the new version?

Hi yes, you don’t need to uninstall too if you update via FTP, just overwrite all the files to get update.
Regards

Many thanks for that Sike.

Can I add a custom Image for the hotspots? I want to be able to place an image/custom icon anywhere on the site, just how the hotpot works. willing to pay for a feature like this. Let me know if your plugin offers this?

Hi, I’m having problems with the plugin. After adding an HotSpot element and adding an image via the HotSpotSettings and leaving everything else by its default (all the [hotspotitem]), in the frontend there’s the image with all the hotspots but the popups don’t show on hover.

Hi, thanks for your fast reply. The preview is here: https://missmaryshop.de/ (still in developement), you find the section with the plugin at the bottom of the page

sike

sike Author

Hi, I notice your site’s plugin openswatch also using the tooltipster, which may conflict with this plugin’s custom one. Please try to disable it?
Regards

Hi, disabling the Open Swatch Plugin made HotSpots work. Is there a solution to fix the confilct between the two plugins? I need both plugins. :-)

Hi Sike, please answer to my last question. Is there a way to make your HotSpot Plugin work together with the WooCommerce Open Swatch Plugin? Thanks :-)

sike

sike Author

Hi, can you send me your WP and FTP account via the contact form in my profile page, then I can update file to test. Or you can try to disable the tooltipster in Open Swatch plugin which you may not use it.
Regards

Hi there

I’ve got an issue with making full-width image with htspot on hover…I’m using VC 5.1.1 in a HighGrade Theme…

could u please help me to fix it?

Thanks a lot

GM

sike

sike Author

Hi, please send me the preview page and how to reproduce the problem, then I can try to help.
Regards

just sent u an email

by
by
by
by
by
by