Discussion on Vimeo SEO user playlist for wordpress

ceasar

ceasar supports this item

Supported

This author's response time can be up to 1 business day.

74 comments found.

Hey man,

I think I need a CSS fix. I’m using the Bridge theme with Visual Composer and inserted a short code for an album, but the video and the playlist is hanging over the right side of the background container. How can I fix that. http://impact-church.tv/media-library

box sizing problem.

Add

#vimeo_holder, #vimeo_holder .vimplayer ul.videovim li a, #vimeo_holder .vimplayer ul.videovim li a.currentvideo  {
    -moz-box-sizing: content-box!important;
    -webkit-box-sizing: content-box!important;
    box-sizing: content-box!important;
}

to wp-content/plugins/vimeoplaylist/vimeoplaylist.css

added under support tab http://codecanyon.net/item/vimeo-seo-user-playlist-for-wordpress/2821347/faqs/21199

Hey Ceasar,

great plug-in, the slideshow autoplay was exactly what I’m after (love it when you google and it exists :-). I’d just reiterate what others have said about being able to pull in private videos / hidden videos / moderated playlists in a future release (at least one of them). On a minor note, I think the documentation could be a little clearer.

Thanks!

Jon

Hai Jon. Thanks, perhaps I will add this, I will put it on the list :-)

Hey Ceasar,

I’ve a question which might be outside the realm of support… I’m trying to add another element which has a ‘currentvideo’ (or similar) class, but it’s a bit beyond me. i.e. within… foreach( $video->get_videos() as $key => $val ){ I’ve also tried tweaking the js – but it doesn’t seem so simple to me. I’d appreciate any pointers!

Many thanks

Jon

I am on a holiday right now but the current class is already be set. Just check your console in chrome or firebug in ff

Thanks for the reply Ceasar. Sorry to disturb your holiday! I see ‘currentvideo’ is already applied, but I’d like to apply it to another element, if that makes sense. With the current js it can only be applied to the first ‘videoThumbVim’ href element. I’d be grateful if you could advise upon your return. Enjoy your holiday!

That can be set in the js. I cannot help you. I will be back after 10 nov.

I figured it out. I don’t know jquery so it took me a while :-)

In the js I added…

var firstVideo = $(".vimtitle").filter(function (index) { return index == options.playfirst }).addClass('currentheader');

and then adding and removing the class like this for example where necessary…

selector.prev().filter('.currentheader').removeClass('currentheader');

Might not be the best way but works fine :-)

Great :)

I use InfiniteWP (IWP) to keep track of and update all of my Wordpress websites.

When I login to IWP, I am getting an error report from the website I am using this plugin on.

The response that IWP is giving me is:

PHP Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method VimeoPlaylistPlugin::hook_plugin_init() should not be called statically in C:\\Inetpub\\vhosts\\my.server.com\\site1\\wp-includes\\plugin.php on line 505

Can you tell me if there is something I can to do resolve this?

I am on a holiday right now, but this is just a strict warning and can be ignored. In your php.ini set off the strict warnings

Thanks! Hope you have a great holiday.

Hi Ceasar – Hope you had a good holiday :)

Can we play private videos yet? I want to purchase but that is a deal breaker for me.

juneink@gmail.com

Sorry, not with this app. ( holiday was okay :-) thanks )

Hi Ceasar, hoy to put the code in responsive mode?

[vimeolist username=”wayman”]

thanks

Hi there,

I wish to hide the play controls until someone hovers over the video. Please advise asap what little bit of code I need to adapt? Thanks so much.

Hello, I recently purchased on my companies account. Could you help me to remove the player border and not show the other videos in the playlist. I’m wanting it to just look like a plain video embed. Thank you for any help.

logan

Show a url where the player is showing and set here your shortcode

Here’s the link to the page – http://theoutsidersclub.com/portfolio_page/bug-hunt/ Here’s the shortcode I’m using - [vimeolist username=”776577” type=”channel” titlelength=”60” desclength=”150” slideshow=”0” playlistheight=”00” playerwidth=”920” thumb_right=”0” color=”#8DAA52” centerPlayer=”1”]

I have a landing page for the website now. Could you let me know when you would be available to check it out and I’ll take off the landing page.

I’m still trying to figure out how to get the player in the left column. My goal is to have it look like the flattrack video embedded on the top left. Thank you logan

http://www.template-responsive.nl/wpdemos/loganhursh/

Here you will find the css you will have to adjust. The position you have to do for yourself. Just use FF or Chrome to adjust the css to your needs and then adjust the WP css file

Can we add private (Password Protected) videos in this?

Please read my above comments. You have set an password so now it don’t work anymore. Yesterday I saw them and made you a demo Nothing more I can do about this.

This is not a way. I removed password. Before buy I cleared my concern with you. This is cheat :-(

Please concern your words or I will do a staff request to remove you.

I already told you that with the simple API it wouldn’t work. You wrote that it still can be embedded so I made a demo which works yesterday. Now you changed something on Vimeo so that it won’t work.

Read this whole thread carefully again and never accuse me of cheating.

I will not answer anymore of your questions as I did more then enough to help you out and is beyond the normal scope of the Envato support rules.

And as you look now it works as expected http://www.template-responsive.nl/wpdemos/akspat66/ (clear your cache, set Cache to false in your admin)

Hi, Should this still be working with the recent Vimeo update? My player is now stopping at the end of the first video rather than playing the whole playlist. Any ideas on something I could try out to fix this? thanks -logan

Just check your browser console or show or sent a live url

Okay, I am getting a js error:

Failed to execute ‘postMessage’ on ‘DOMWindow’: The target origin provided (‘http://player.vimeo.com') does not match the recipient window’s origin (‘http://theoutsidersclub.com').

Could you help me out with this?

If you want to check out a page with the error, here is the info:

Link: http://theoutsidersclub.com/portfolio_page/paracord-crafts-sailing-salsa-challenge2/

Password: password

Thanks for the help logan

This doesn’t look like my player at all. So you probally adjusted the files. No playlist to see. If I click on the player progress bar it sends me to http://theoutsidersclub.com/wp-content/uploads/2015/03/beach.jpg. (IE 11) So I really don’t know what is messing things up. You load so many js files in your theme or plugins. So better first clean up all the not used js files, then remove them one by one to see what files are conflicting. If you search for failed to execute ‘postmessage’ on ‘domwindow’ the target origin provided you will find some info why this problem occurs.

Also you have an link over the iframe to /wp-content/uploads/2015/03/beach.jpg and the next video gives an http://player.vimeo.com/video/undefined (FF)

So, there is a 20 videos limit? That is awful…no way to go around that? Cheers

Ok. It would be a good idea to add the new API. 20 videos limit is very low. At least you should make this limitation visible for anyone who wants to buy the plugin. I bought it and I had no idea that the limit is 20 videos. Cheers

The limitation has been written on the Item detail tab

Ok thanks!

Hi,

Is your plugin capable and allows registered users to create their own playlist please?

What I mean is, I dont want them to go to a wordpress backend, instead, once they have signed up to my website. They can access a special page that allows them to create their own video playlists. Is this possible?

Please replay. Thanks!

For referances, please go to http://devour.com/ and see their playlist there. Thanks!

Sorry , not possible

This is not working for me. It removes all content from the page and give me a blank square. Weird. Take a look: http://morflearning.com/testerportal/

this doesnt appear to be mobile responsive… Is there a way to make it responsive?

Excellent support!

by
by
by
by
by
by