7 comments found.

Is the code eclipse comaptible OR android studio ?

Sorry, the code is only compatible with Eclipse.

Leaderboard i s there ?

Yes, ‘Leaderboard |Google Play game services’ is incorporated in the app.

Hi! I want to buy this. I have two questions.

1. leader board is not opening your sample app? will you help getting it done?

2. also I need to add Indian languages, it fine or not?

Dear rajeevkumarsingh,

1. Since the app is not uploaded on Play store, the leaderboard won’t work. First you need to upload the app on Play store and add the values of your App id and leaderboard id in the code. Then only leaderboard will work.

2. There is very little text in the app, which is written at the same place in the code. And to answer your question yes you can change the language.

leaderboard not working. Not able to see signin popup.

?

Sorry for the late reply, I had to go through the whole code. I found out that two piece of lines were omitted by mistake. Open the file named Start.java in com.coldgravity.tapthedots.helper package and search for the given code below
highscoreImage.addListener(new ClickListener() { @Override public void clicked(InputEvent event, float x, float y) { Sounds.getInstance().play(); if(TapTheDots.actionResolver!=null&&TapTheDots.actionResolver.isSignedIn()) TapTheDots.actionResolver.showLeaderboard(); } });
Now just below the line
Sounds.getInstance().play();
Add the following lines
if(TapTheDots.actionResolver!=null && !TapTheDots.actionResolver.isSignedIn()) TapTheDots.actionResolver.login();else

Finally the code will look like below
highscoreImage.addListener(new ClickListener() { @Override public void clicked(InputEvent event, float x, float y) { Sounds.getInstance().play(); if(TapTheDots.actionResolver!=null && !TapTheDots.actionResolver.isSignedIn()) TapTheDots.actionResolver.login(); else if(TapTheDots.actionResolver!=null&&TapTheDots.actionResolver.isSignedIn()) TapTheDots.actionResolver.showLeaderboard(); } });

I have also added this in the new update so you can either wait for it or can do it easily yourself.

Okay thanks, this resolved the problem. Highly appreciated.

Hi, Eclipse gives me this error when importing files and appears with a red exclamation:

[06/24/2015 20:44:29 – BaseGameUtils] Unable to resolve target ‘android-19’

[06/24/2015 20:44:29 – TapTheDots-android] Unable to resolve target ‘android-19’

[06/24/2015 20:44:48 – google-play-services_lib] Unable to resolve target ‘android-19’

Dear JaviMarin90, Its easy to remove that error, follow these steps:

1. Right click on the project in Eclipse and then select properties.

2. Select android tab and then in the upper part select the Andriod sdk you have installed.

What version? Also it gives these errors

Project ‘TapTheDots-android’ is missing required Java project: ‘TapTheDots’ TapTheDots-android Project ‘TapTheDots-android’ is missing required library: ’\TapTheDots\libs\gdx.jar’ The project cannot be built until build path errors are resolved TapTheDots-android

To change the android version:

1. Right click on “TapTheDots-android”, select properties.

2. Make sure “Android” is selected from the left panel of the pop-up.

3. Under “Android”, “Project Build Target” various android version will be shown, if ‘Android 4.4.2 , 19 API Level’ is not there then select any android version by clicking on the checkbox.

To remover build path error:

1. Right click on “TapTheDots-android”, select “Build path”, then “configure build path”.

2. Make sure “Java Build Path” is selected from the left panel of the pop-up.

3. Also make sure under “Java Build Path” “Libraries” is selected.

4. Under that either you’ll see a cross mark on “gdx.jar – TapTheDots/libs” or you won’t see it at all. If its there with cross mark, select it and click on “Remove”.

5. Now to add the JAR again, on right side panel of the same pop-up, click on “Add JARs…”.

6. Browse the file in the list shown, “TapTheDots” > “libs” > “gdx.jar”. Click “ok” to add it.

Repeat the same steps for “TapTheDots-android” and “TapTheDots-desktop” if required.

Description Resource Path Location Type The project cannot be built until build path errors are resolved TapTheDots-android Unknown Java Problem

Description Resource Path Location Type Project ‘TapTheDots-android’ is missing required library: ’\TapTheDots\libs\gdx.jar’ TapTheDots-android Build path Build Path Problem

Description Resource Path Location Type Project ‘TapTheDots-android’ is missing required Java project: ‘TapTheDots’ TapTheDots-android Build path Build Path Problem

help me pls got error like this

Excellent job bro

by
by
by
by
by
by