50 comments found.

Hello I am having error R cannot be resolved to a variable ?

Hi, You must have changed the packagename of the file before the one of the manifest file. To solve it just go to the file that has errors and remove the import that contains an ‘R’.

Is there a manual on how to import into Android Studio opposed to Eclipse? I have tried over and over and can’t get it to go.

Hi, I have made no tutorials for this specific app. However, there are many tutorials online that cover this. Do you have a specific error that I can help you with, perhaps?

No error, just trying to import into Android Studio since I am not using Eclipse. I’ll figure it out eventually. Thanks anyway.

Hi, I downloaded the latest version. When you run the application, I get an error. What is the problem? thanks in advance.

08-02 17:12:45.732: D/AndroidRuntime(13939): Shutting down VM 08-02 17:12:45.732: W/dalvikvm(13939): threadid=1: thread exiting with uncaught exception (group=0×4c8ea160) 08-02 17:12:45.742: E/AndroidRuntime(13939): FATAL EXCEPTION: main 08-02 17:12:45.742: E/AndroidRuntime(13939): Process: com.companyname.Glasssmasher, PID: 13939 08-02 17:12:45.742: E/AndroidRuntime(13939): java.lang.RuntimeException: Unable to resume activity {com.companyname.Glasssmasher/com.companyname.Glasssmasher.Glasssmasher}: java.lang.NullPointerException 08-02 17:12:45.742: E/AndroidRuntime(13939): at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2960) 08-02 17:12:45.742: E/AndroidRuntime(13939): at android.app.ActivityThread.handleResumeActivity(ActivityThread.java:2989) 08-02 17:12:45.742: E/AndroidRuntime(13939): at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2406) 08-02 17:12:45.742: E/AndroidRuntime(13939): at android.app.ActivityThread.access$800(ActivityThread.java:139) 08-02 17:12:45.742: E/AndroidRuntime(13939): at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1293) 08-02 17:12:45.742: E/AndroidRuntime(13939): at android.os.Handler.dispatchMessage(Handler.java:102) 08-02 17:12:45.742: E/AndroidRuntime(13939): at android.os.Looper.loop(Looper.java:149) 08-02 17:12:45.742: E/AndroidRuntime(13939): at android.app.ActivityThread.main(ActivityThread.java:5273) 08-02 17:12:45.742: E/AndroidRuntime(13939): at java.lang.reflect.Method.invokeNative(Native Method) 08-02 17:12:45.742: E/AndroidRuntime(13939): at java.lang.reflect.Method.invoke(Method.java:515) 08-02 17:12:45.742: E/AndroidRuntime(13939): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:794) 08-02 17:12:45.742: E/AndroidRuntime(13939): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:610) 08-02 17:12:45.742: E/AndroidRuntime(13939): at dalvik.system.NativeStart.main(Native Method) 08-02 17:12:45.742: E/AndroidRuntime(13939): Caused by: java.lang.NullPointerException 08-02 17:12:45.742: E/AndroidRuntime(13939): at com.companyname.Glasssmasher.Glasssmasher.onResume(Glasssmasher.java:85) 08-02 17:12:45.742: E/AndroidRuntime(13939): at android.app.Instrumentation.callActivityOnResume(Instrumentation.java:1192) 08-02 17:12:45.742: E/AndroidRuntime(13939): at android.app.Activity.performResume(Activity.java:5490) 08-02 17:12:45.742: E/AndroidRuntime(13939): at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2950) 08-02 17:12:45.742: E/AndroidRuntime(13939): ... 12 more

Hi, Thanks for your purchase! This probably occurred because you didn’t put any Admob ad unit id.

Is there a quick way for me to remove all the boards except for one?

You help would be appreciated :)

Hi, Unfortunately, to change the number of boards you need to change some lines of code. Open surface.java: 1)in line43 remove all titles but one:
    String[] boardtitle = new String[] { "Gentle"};
2) in line 139, remove the extra images
        //load soundboard 2 images
        rawsoundicon[0][1] = BitmapFactory.decodeResource(getResources(), R.drawable.smash1);
        rawsoundicon[1][1] = BitmapFactory.decodeResource(getResources(), R.drawable.smash2);
        rawsoundicon[2][1] = BitmapFactory.decodeResource(getResources(), R.drawable.smash3);
        rawsoundicon[3][1] = BitmapFactory.decodeResource(getResources(), R.drawable.smash4);
        rawsoundicon[4][1] = BitmapFactory.decodeResource(getResources(), R.drawable.smash5);
        rawsoundicon[5][1] = BitmapFactory.decodeResource(getResources(), R.drawable.smash6);
        rawsoundicon[6][1] = BitmapFactory.decodeResource(getResources(), R.drawable.smash7);
        rawsoundicon[7][1] = BitmapFactory.decodeResource(getResources(), R.drawable.smash8);
        rawsoundicon[8][1] = BitmapFactory.decodeResource(getResources(), R.drawable.smash9);
        //load soundboard 3 images
        rawsoundicon[0][2] = BitmapFactory.decodeResource(getResources(), R.drawable.extreme1);
        rawsoundicon[1][2] = BitmapFactory.decodeResource(getResources(), R.drawable.extreme2);
        rawsoundicon[2][2] = BitmapFactory.decodeResource(getResources(), R.drawable.extreme3);
        rawsoundicon[3][2] = BitmapFactory.decodeResource(getResources(), R.drawable.extreme4);
        rawsoundicon[4][2] = BitmapFactory.decodeResource(getResources(), R.drawable.extreme5);
        rawsoundicon[5][2] = BitmapFactory.decodeResource(getResources(), R.drawable.extreme6);
        rawsoundicon[6][2] = BitmapFactory.decodeResource(getResources(), R.drawable.extreme7);
        rawsoundicon[7][2] = BitmapFactory.decodeResource(getResources(), R.drawable.extreme8);
        rawsoundicon[8][2] = BitmapFactory.decodeResource(getResources(), R.drawable.extreme9);
3) in line 193, remove:
    boardtitlecolor[1].setARGB(255, 217, 127, 1);
        boardtitlecolor[2].setARGB(255, 217, 41, 1);

Is this app using the new admob sdk ???

Yes, it does. It was updated in version 3

Waiting for android studio version

ok, I will convert it to Android Studio for you. Just send me an email when you purchase.

Hi, I Already purchase your code, please send Android Studio version to my email : ayunindyasophia@gmail.com

sending it in a few minutes

Hi, Is the audio stored locally (offline)?

yes, it will be stored in the app

hi neaurondigital. I have a question..If i buy now, can you give me android studio version to me (without ads code) ? Thanks in advance for a response

Hi, Thanks for your interest! Sure. I have added an Android Studio version. When you buy it you will get the eclipse and Android Studio version. If you do not insert an ad unit id ads should not show.

Did you have iOS version of the app ?

I’m afraid I only have the Android version.

crush76

crush76 Purchased

Hi its me again, i have one issue and need your help, i imported the code to eclipse with everything fine no errors or anything, i compile the code and get the apk, but once i install it on phone it crash, i have tried on 3 different phones, HTC 10, HTC M8, and samsung S5…

It’s great that the app is working on eclipse. So the above error is being generated in Android Studio? What I meant in my previous comment was, Is there an error log being shown in Android Studio logcat. This should give us an indication from where the error is originating.

crush76

crush76 Purchased

i didnt try Android Studio, only eclipse, as i dont use Android Studio, i imported the code to eclipse, then i compiled the apk, once installed on phone it crashes or stop..

Ok that is fine. Eclipse should also have logcat build in. Just check it to see the full error. Feel free to send me a screenshot or a copy of the error.

by
by
by
by
by
by