Code

Discussion on Slider Revolution Responsive Magento Extension

nwdthemes

nwdthemes supports this item

Supported

This author's response time can be up to 2 business days.

1511 comments found.

I need to set two different text shadow value on a layer for <= tablet size and for > tablet screen size, but I can’t figure how to do this. I suppose I can do it using a @media query, but probably I use a wrong syntax in layer’s Advanced CSS because the code changes by himself when I try to save it. How can I set “text-shadow: 2px 2px black;” on a layer for 768 px and less screen size and “text-shadow: 4px 4px black;” for higher resolution?

Resolved. My mistake was because I added the style to the layer and not to the CSS of the slider.

Hi Pascal

Glad you have this resolved.

Thanks a lot,

Cheers from your Team @ NWDthemes

Follow us on Facebook Twitter

Is it possible to copy a slide from a slider to another (or import a slider into another appending it at the end without overwrite existing slides)

I’ll wait for the update. Thank you

Please upload updated files from m1 folder of this archive. It will solve problems with adding and loading user tempaltes.

http://nwdthemes.com/files/fix_user_templates.zip

It works perfectly, thank you!

We bought the slider revolution for our Magento installation recently. Unfortunately our site has been hacked and we are starting a new website from scratch. Is it possible to get the installation files to put it back on?

Hi

Sure, you can download recent version of extension files in your CodeCanyon downloads page: https://codecanyon.net/downloads

Thanks a lot,

Cheers from your Team @ NWDthemes

Follow us on Facebook Twitter

Hello!

I am having a small issue upgrading to the newest version of your extension for magento. I am hoping this is a quick change and I am hoping you can help me or point me in the right direction. I think its the call in Framework.php and the way they are written that causes this. This function

self::$RS_PLUGIN_PATH = Mage::getSingleton(‘core/design_package’)->getSkinBaseDir(array(‘_theme’ => ‘default’)) . ’/nwdthemes/revslider/’; self::$RS_PLUGIN_URL = Mage::getDesign()->getSkinUrl(‘nwdthemes/revslider/’) ;

We have JS and CSS versioning implemented in our site. And it is causing your calls to

https://local.north40.com/skin/adminhtml/default/default/nwdthemes/revslider/?v=1487021134admin/assets/css/edit_layers.css Failed to load resource: the server responded with a status of 403 ()

put the version in the middle of the URL. I don’t care if we just strip out the versioning completely. Is there an easy way to do this? I was trying to just work it out on my own but I am a bit stuck so any help would be appreciated.

Thanks! Lauri

Hi Lauri

To make it define plugin url correctly in case of get skin url contains extra arguments you can change this line:

self::$RS_PLUGIN_URL = Mage::getDesign()->getSkinUrl(‘nwdthemes/revslider/’) ;

In following way:

list(self::$RS_PLUGIN_URL) = explode('?', Mage::getDesign()->getSkinUrl('nwdthemes/revslider/'));

We will make this change in next version too to make it work correctly in such cases.

Thanks a lot,

Cheers from your Team @ NWDthemes

Follow us on Facebook Twitter

I’ve just installed your extension. The customer says that there’s an error on the “animation” function. The javascript console log is:

8a218fe….js:33106 Uncaught TypeError: Cannot read property ‘frame_0’ of undefined at theLayerInAnimation (8a218fe….js:33106) at Object.t.animateCurrentSelectedLayer (8a218fe….js:32968) at HTMLLIElement.<anonymous> (8a218fe….js:32011) at HTMLLIElement.dispatch (8a218fe….js:21023) at HTMLLIElement.r.handle (8a218fe….js:21023) theLayerInAnimation @ 8a218fe….js:33106 t.animateCurrentSelectedLayer @ 8a218fe….js:32968 (anonymous) @ 8a218fe….js:32011 dispatch @ 8a218fe….js:21023 r.handle @ 8a218fe….js:21023

Could you help me?

Hi

Please download and apply this updated files related to your Magento version to fix animations tab errors:

http://nwdthemes.com/files/fix_animations_tab.zip

Thanks a lot,

Cheers from your Team @ NWDthemes

Follow us on Facebook Twitter

Hello,

Your plugin has an error when merging JS in Magento. After some of your functions, there is none ”;” sign.

Would be good, if the module is tested for merging, cause it is breaking JS.

Would be happy to see this in next updates, as we use your module on many sites for customers.

Hi

We do test merged mode on clean install and it is working fine. However, there are might be issues with 3rd-party extensions. Could you share the changes you did? We will check them and add in new update.

Thanks a lot,

Cheers from your Team @ NWDthemes

  Facebook      Twitter

Hey , rev slider is not running after make merge and compress js on magento 2.

Hi

Problem might come from conflict with JavaScript Bundling mode and JavaScript Merge mode options.

In recent discussion with Magento team front end developers they explained that Bundle is used to optimize loading of dynamic required scripts that use require.js. And merge option is used to speed up loading of old way embedded scripts. When both Bundle and Merge modes are enabled it can lead to unstable work and decrease effect of each separate mode. In future they are going to restrict enabling of both conflicted modes same time so it is advised not to use them together.

Disabled JavaScript Bundle mode in your store developers settings and it should fix the problem.

Thanks a lot,

Cheers from your Team @ NWDthemes

  Facebook      Twitter

I want to buy the extension for my client . I need to know if its will supported after minify js files by default

Hi

We do test merged mode on clean install and it is working fine.

Thanks a lot,

Cheers from your Team @ NWDthemes

  Facebook      Twitter

Hi Support, I have problem with performance of revolution slider on multi-store. Default store works fine but our language stores are very slow on all pages with slider present. When slider is disabled, all stores are loading fast. Would you have any suggestion on how to resolve this issue. Many Thanks

Hi

We have tested it on multi-store site and it worked pretty fast. Please provide admin / ftp credentials to nwdthemes@gmail.com so we can investigate it to find reason and improve its performance.

Thanks a lot,

Cheers from your Team @ NWDthemes

  Facebook      Twitter

We installed this on Magento 2.1.5 and it does not function as expected, we have installed it according to the instructions, but many of the javascript functions are not working.

IE on settings for a slider, when you click a “tab” it does not throw a javascript error, but it won’t tab over. A lot of the usability is very buggy when editing a slide. So i’m not sure if there is some sort of javascript conflict. We are using the base LUMA theme with no core code modified.

Please provide admin / ftp credentials to nwdthemes@gmail.com . We will check the issue.

Credentials have been sent

Thanks for the credentials. Checked them, all is working. Will update you via email

Hello,

I’m working with Magento 1.9.2. My website is available in many languages. www.davidts.eu

I’ve create a slider on homepage (one slider for each language).

Time to time the slider is not displayed in French or in English but is working fine in the other homepages but i don’t understand why.

Could you help me?

Hi

It could be either slider setup issue or cache related issue.

1. Please check that you have assigned correct store views

2. Clear magento cache. If you are using any 3rd-party cache extensions – flush their cache.

Thanks a lot,

Cheers from your Team @ NWDthemes

  Facebook      Twitter

Hello

I have a question concerning the module i bought to you The revolution slider for Magento.

We use actually Magento 2.1.5. Is revolution slider module completely compatible with this version? On themeforest it is indicated version 2.1.3 for Magento

Thanks. We don’t want to have problem because our Magento 2.1.5 is very stable.

Thanks MR LATREILLE Retouche Peinture

Hi Mr Latreille

We just tested our extension with recent 2.1.5 Magento version and no issues was detected. So it is safe to use Slider Revolution with this Magento version.

We will update compatibility details for this product once new option will be available there for selection. 2.1.3 is the latest option available there so far.

Thanks a lot,

Cheers from your Team @ NWDthemes

Follow us on Facebook Twitter

When we add a non secure (http://) link in our slider, the url is auto changes to a secure link (https://). How do we fix this?

https://www.glowbioticsmd.com/storelocator

First Slider, 2nd slide called SkinWestChester is supposed to be a non secure URL but shows up as a secure URL

Hi

We are planning to make this url protocol conversion optional or give ability to user to add exceptions to it. It will be implemented in future releases.

For now you can try to omit protocol in url to let it be auto detected. So url will look like this: //nwdthemes.com

Or you can edit forceSSL function located in /app/code/community/Nwdthemes/Revslider/Helper/Framework.php:380

Comment out code inside function to stop conversion. Or add code to replace particular url back to http before function return.

Thanks a lot,

Cheers from your Team @ NWDthemes

Follow us on Facebook Twitter

Hi,

i just enabled production mode in my Magento 2 shop, including javascript merge and minimize. Since I did this, the slider stopped working. I have no idea why. Page: http://magento2.p372223.webspaceconfig.de/

Best regards Tobias Knobloch

Hi

Problem might come from conflict with JavaScript Bundling mode and JavaScript Merge mode options.

In recent discussion with Magento team front end developers they explained that Bundle is used to optimize loading of dynamic required scripts that use require.js. And merge option is used to speed up loading of old way embedded scripts. When both Bundle and Merge modes are enabled it can lead to unstable work and decrease effect of each separate mode. In future they are going to restrict enabling of both conflicted modes same time so it is advised not to use them together.

Disabled JavaScript Bundle mode in your store developers settings and it should fix the problem.

Thanks a lot,

Cheers from your Team @ NWDthemes

  Facebook      Twitter

Please Help me With This issue

See the link for Screenshot Provided

http://www.screencast.com/t/KeTw9MjlDEv

Now I am Having Critical Problem with my Slider. Animated Layers Are Not Showing on First Slider Load. Those Are Showing After 3-5 Times Reloading the Frontend Page, Even Sometime Not Showing All Layers. Non- Animated Layers are Working Fine.

Please Help

Please See this Video For the Issues in The New Version

http://www.screencast.com/t/GHMKwGcFq9

HI

1. Please provide an URL with the issue. We will check it

2. Thanks for bug report. I’ll go ahead and add it to the official request list so it can get reviewed for a future update by our development team

Hi, I purchased revolution slider with a theme undsgn, i work in localhost and the plugin doesn’t work, i can install but not activate. When i try to activate appear a fatal error like this: Fatal error: Uncaught Error: [] operator not supported for strings in /Applications/MAMP/htdocs/test/wp-content/plugins/revslider/includes/framework/base-admin.class.php:71 Stack trace: #0 /Applications/MAMP/htdocs/test/wp-content/plugins/revslider/admin/revslider-admin.class.php(572): RevSliderBaseAdmin::addMetaBox(‘Revolution Slid…’, ’’, Array, NULL) #1 /Applications/MAMP/htdocs/test/wp-content/plugins/revslider/admin/revslider-admin.class.php(73): RevSliderAdmin->addSliderMetaBox() #2 /Applications/MAMP/htdocs/test/wp-content/plugins/revslider/admin/revslider-admin.class.php(44): RevSliderAdmin->init() #3 /Applications/MAMP/htdocs/test/wp-content/plugins/revslider/revslider.php(162): RevSliderAdmin->__construct(’/Applications/M…’) #4 /Applications/MAMP/htdocs/test/wp-admin/includes/plugin.php(1882): include(’/Applications/M…’) #5 /Applications/MAMP/htdocs/test/wp-admin/plugins.php(164): plugin_sandbox_scrape(‘revslider/revsl…’) #6 {main} thrown in /Applications/MAMP/htdocs/test/wp-content/plugins/revslider/includes/framework/base-admin.class.php on line 71 How can I activate the plugin in localhost? thank you

Hi

As you have received our extension via a theme purchase, there are two options:

1. Help from authors of included third party assets

If a supported item includes a third party asset (e.g. a plugin or slider), the author of the third party asset is not required to provide support for that asset to buyers of the supported item. Direct your questions about third party assets to the author of the item you purchased.

2. If you need direct support from us, you can purchase an extension license from us.

We hope that this clears things up a bit!

Thanks a lot,

Cheers from your Team @ NWDthemes

  Facebook      Twitter

Hi, I purchased revolution slider with a theme undsgn, i work in localhost and the plugin doesn’t work, i can install but not activate. When i try to activate appear a fatal error like this: Fatal error: Uncaught Error: [] operator not supported for strings in /Applications/MAMP/htdocs/test/wp-content/plugins/revslider/includes/framework/base-admin.class.php:71 Stack trace: #0 /Applications/MAMP/htdocs/test/wp-content/plugins/revslider/admin/revslider-admin.class.php(572): RevSliderBaseAdmin::addMetaBox(‘Revolution Slid…’, ’’, Array, NULL) #1 /Applications/MAMP/htdocs/test/wp-content/plugins/revslider/admin/revslider-admin.class.php(73): RevSliderAdmin->addSliderMetaBox() #2 /Applications/MAMP/htdocs/test/wp-content/plugins/revslider/admin/revslider-admin.class.php(44): RevSliderAdmin->init() #3 /Applications/MAMP/htdocs/test/wp-content/plugins/revslider/revslider.php(162): RevSliderAdmin->__construct(’/Applications/M…’) #4 /Applications/MAMP/htdocs/test/wp-admin/includes/plugin.php(1882): include(’/Applications/M…’) #5 /Applications/MAMP/htdocs/test/wp-admin/plugins.php(164): plugin_sandbox_scrape(‘revslider/revsl…’) #6 {main} thrown in /Applications/MAMP/htdocs/test/wp-content/plugins/revslider/includes/framework/base-admin.class.php on line 71 How can I activate the plugin in localhost? thank you

Hi

As you have received our extension via a theme purchase, there are two options:

1. Help from authors of included third party assets

If a supported item includes a third party asset (e.g. a plugin or slider), the author of the third party asset is not required to provide support for that asset to buyers of the supported item. Direct your questions about third party assets to the author of the item you purchased.

2. If you need direct support from us, you can purchase an extension license from us.

We hope that this clears things up a bit!

Thanks a lot,

Cheers from your Team @ NWDthemes

  Facebook      Twitter

We installed the new version of the extension and when we add an object in a slider we recieve all errors below:

/pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:21 JQMIGRATE: Logging is active /pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:41 JQMIGRATE: jQuery.fn.attr(‘checked’) may use property instead of attribute migrateWarn @ /pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:41 /pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:43 console.trace migrateWarn @ /pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:43 /pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:41 JQMIGRATE: jQuery.fn.attr(‘selected’) may use property instead of attribute migrateWarn @ /pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:41 /pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:43 console.trace migrateWarn @ /pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:43 /pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:41 JQMIGRATE: ‘hover’ pseudo-event is deprecated, use ‘mouseenter mouseleave’ migrateWarn @ /pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:41 /pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:43 console.trace migrateWarn @ /pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:43 /pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:41 JQMIGRATE: jQuery.fn.andSelf() replaced by jQuery.fn.addBack() migrateWarn @ /pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:41 /pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:43 console.trace migrateWarn @ /pub/static/adminhtml/Magento/backend/en_US/jquery/jquery-migrate.js:43 /pub/static/adminhtml/Magento/backend/en_US/mage/loader_old.js:191 Expected to start loader but did not find one in the dom

Hi

Try to clear the pub/static directory of all files except .htaccess (which is a hidden file). Enter the following command:
rm -R pub/static/*
Regenerate static files:
php bin/magento setup:static-content:deploy
Clean cache:
php bin/magento cache:clean

I noticed that your support license has expired. It would be awesome if you can renew it, so that we can still give you further support.

http://nwdthemes.com/2016/06/14/codecanyon-extended-support-faq/

Thanks a lot,

Cheers from your Team @ NWDthemes

  Facebook      Twitter

Hello,

I have had the Revolution slider extension installed in my Magento store for about a month, and it has worked just fine until yesterday.

Now, when I try to access a saved slider, I get this error:

“Field Slide ID should not be empty”

Can you please help me to resolve this? I can not edit or create any sliders now, and I am about to take my site live. Thanks

Hello, I worked with my server company and re-installed the extension. I can save a new slider, but when I click to the “Slide Editor”, it reloads the setting page instead.

Also, on the server configuration check, it should Ok for all checks under “System Requirements”, but I still can not figure out why this broken, no changes were made to it directly

Suhosin or mod_security cant be detected via php if you compiled suhosin as a part of your PHP interpreter. Some hosts appear to not return all of the apache mods.

Did you check settings mentioned in my previous post?

Hi, I use Typekit for my fonts on my site. Is there a way that I can use my fonts in your slider? We are running Magento 1.9 and using Revolution slider.

Thank you

Hi

1. Upload your font to media/fonts/

2. Login to admin, go to slider settings and open CSS / Javascript section in the bottom

3. Insert this code into custom css

@font-face { font-family: myfont; src: url(’//demo.com/media/fonts/myfont.ttf’); }

4. Go to Edit Slides and select slide you want to edit

5. Create / select text layer and update it to
<span style="”font-family:"> CATCHING</span>

Thanks a lot,

Cheers from your Team @ NWDthemes

  Facebook      Twitter

by
by
by
by
by
by