Discussion on Paypal Digital Goods for Easy Digital Downloads

magnigenie

magnigenie supports this item

Supported

11 comments found.

do you handle subscriptions

Hi, Currently it works only with purchases. We are planning to add the support for recurring payment in future.

A license registration and subscription module would be terrific , but good luck with sales :)

Thanks, we are currently working on some plugin for Easy digital downloads. Will definitely include this to our list.

Thanks for the appreciation.

Nice work my dear

Its not working Plugin could not be activated because it triggered a fatal error.

Hi,

The problem I see is that you are not using easy digital downloads on your site and that’s why its not working. Please note that this plugin is an addon for easy digital downloads.

Regards

Now what I need to do ??

You mean to say you that you don’t need this plugin ? I guess you were looking for something for woocommerce?

Another Fatal error – but I actually do have EDD installed lol

Fatal error: Uncaught exception ‘Exception’ with message ‘username needs to be set’ in /var/www/html/wp-content/plugins/edd-paypal-digital-goods/lib/paypal-configuration.class.php:172 Stack trace: #0 /var/www/html/wp-content/plugins/edd-paypal-digital-goods/lib/paypal-configuration.class.php(259): PayPal_Digital_Goods_Configuration::get(‘username’) #1 /var/www/html/wp-content/plugins/edd-paypal-digital-goods/lib/paypal-configuration.class.php(197): PayPal_Digital_Goods_Configuration::set_or_get(‘username’, NULL) #2 /var/www/html/wp-content/plugins/edd-paypal-digital-goods/includes/class-edd-paypal-digital-goods.php(16): PayPal_Digital_Goods_Configuration::username(NULL) #3 /var/www/html/wp-content/plugins/edd-paypal-digital-goods/edd-paypal-digital-goods.php(29): EDD_Paypal_Digital_Goods->__construct() #4 /var/www/html/wp-admin/plugins.php(151): include(’/var/www/html/w…’) #5 /var/www/html/wp-admin/plugins.php(153): plugin_sandbox_scrape(‘edd-paypal-digi…’) #6 {main} thrown in /var/www/html/wp-content/plugins/edd-paypal-digital-goods/lib/paypal-configuration.class.php on line 172

We have fixed the problem for you. Please check

Excellent, thank you again for your immediate response and resolution! Can you confirm whether this was an error with the plugin or my usage?

Hi,

There was some problem in the plugin settings. We are working on an update so that it would be automatically rectified.

Regards

I came to be ignored suddenly so far though I continued exchanging emails about a trouble of this plug in many times.

Please tell me a solution and the reason.

April 17, 2015 12:58 PM Hello!

On earth how does this matter turn out?

I talk about conventional process once again.

A version of EDD purchased [Paypal Digital Goods Payment Gateway for Easy Digital Downloads] at the time of 2.2.8 from Magnigenie company.

However, Because plug in did not work, I asked Magnigenie company for support by an email.

After several times of exchanges, the person in charge of Magnigenie company seemed to want you to teach a user name and a password of my WordPress.

I followed it.

The problem was settled.

However, the next error message came to appear when I paid in Paypal when a version of EDD was beyond 3.0.0.

“Error:” Calling PayPal with action SetExpressCheckout has Failed: The totals of the cart item amounts do not match order amounts.

Thereafter, I downgrade a version of EDD in 2.2.8 and use it.

And I told these to Magnigenie company by an email.

Then, from the person in charge of Magnigenie company, an answer came at Tuesday, March 24, 2015 11:39 a.m.

“Hi,” Please wait till weekend and the update would be available early next week. Regards

However, Thereafter an answer came at April 14, 2015 3:37 p.m. on Tuesday because there was not communication when I contacted me again last time.

” Hello,What do you mean? The plugin isn’t working for you?”

These are process.

Would you solve a problem after explanation in the situation?

I am troubled very much.

Kazuhide Endou

Hi There,

We tested it on multiple sites/servers and it’s working perfectly fine on all the sites we tested.

Seems like the problem might be related to your server configuration. Can you let me know what is the php version on your server?

Regards

Hi there Version of PHP is 5.3.3.

It should work then and if its not working then it might not be configured correctly.

Hi,

I have installed your plugin when i proceed with payment on the front end it gives an error

SetExpressCheckout failed: SSL connect error(35)

Any idea why this is happening and how i can solve it.

Thanks Aaqib

Hello,

Really sorry for your issue. Seems like issue with SSL connection. Can you please create a temp login for your site or replicate the site on a test environment and send the login details and we will have a look at it.

Regards

Hello I followed your link on paypal digital good and it look like if this is not allready activate in the paypal account they have stoped doing it, is taht correct?

do my site need an ssl certificate to use this plugin?

no, you don’t need ssl certificate.

hi support, i cant active plugin. it says EDD Paypal digital goods expects Easy Digital Downloads to be active. This plugin has been deactivated.

Hi,

As per the error the plugin needs Easy Digital Downloads plugin. Our plugin is an addon to easy Digital Downloads. Without that plugin it will not work. So you have to first install Easy digital Downloads.

by
by
by
by
by
by