itthinx

itthinx supports this item

Supported

38 comments found.

fyi – i tried posting on your website and it kept saying the captcha number was wrong – and it wasn’t – so thought I would post here instead.

I am loving this plugin – a great addition to my site. I have made some progress on the forum that I am working on – but I have 2 issues taking place with the forum at this point:

1. When a topic is clicked and the user goes to the single topic page (example: http://dev.brightstarequestriancentre.com/topic/ideas-for-keeping-kids-busy-in-summer/) – the title of the topic and the description of the topic aren’t showing up on the page. I added a comment and that shows up as well as the comment form underneath – but no topic title and description. Is there code that should be added to the single-topic.php file?

2. When a person submits the form for a new topic (on this page: http://dev.brightstarequestriancentre.com/forums/) – there topic is submitted but this info also shows up above the form: Warning: array_keys() expects parameter 1 to be array, string given in /home/brightstar2013/public_html/wp-content/themes/lifeline/framework/helpers/meta_boxes.php on line 91

Warning: array_merge(): Argument #2 is not an array in /home/brightstar2013/public_html/wp-content/themes/lifeline/framework/helpers/meta_boxes.php on line 91

Warning: in_array() expects parameter 2 to be array, null given in /home/brightstar2013/public_html/wp-content/themes/lifeline/framework/helpers/meta_boxes.php on line 92

Any help is greatly appreciated.

Hi sorry for the delay and the captcha issue. Regarding the issues:

On 1 – it sounds like we need to create a template specific for the theme, if we can have access to the theme we can do that for you, or you can also do it yourself if you are able to work with theme templates. The reference for this is http://www.itthinx.com/documentation/groups-forums/themes/ and there is a GitHub repository with templates adjusted for some themes https://github.com/itthinx/groups-forums-templates

On 2 – that warning seems to originate from the theme, I suppose you have debugging enabled but you should alert the theme developer about the issue.

Please let me know about the theme templates.

Hi Kento

I appreciate the response and for offering guidance on alternatives on your main site. We need something quite quickly so, unfortunately, I had to go with another ticket support solution at codecanyon.

However I would be happy to help test the beta regardless if that would be of use. I have a few VPSs spare to which access could be provided for troubleshooting if necessary.

Just let me know as I’m subscribed to this comment thread

thoughts below – take it or leave it I don’t mind it’s your plugin after all!

key features of interest remain the same

ability to upload attachments to topics (essentially the same as tickets in this context I think) (e.g. screenshots)

ability to customise the submit a topic form, however that may be, via templates or otherwise (e.g. what os are you using? what software version number? consistent or intermittent fault?). Such data could be displayed in a “topic/ticket details” area alongside/above the comment reply thread of the support request

I am entering my reply here as the captcha challenge thinks my entry is incorrect 8+3=11

thanks

Thanks again for the suggestions, I’ve marked the thread as well and I’d be happy to give you beta access to test it once we have it ready.

Hi, I have one pre-sale question. There is an existing phpbb forum that we are using for few years. Now we are migrating site from Joomla to Wordpress and we would like to keep all old posts and themes on our new forum. Is that possible?

Best regards,

Dalibor

Hi,

Sorry but that won’t be possible, thanks for considering the plugin though.

Cheers

Is it possible to upload files to a forum response. Also can I password protect a forum. This would allow a user to send out the password to their friends to access, but the general public would not be able to open the topic.

Hi currently not but thanks for the suggestions! :)

hello, live preview is hacked !!

Hi, many thanks, yes some are on a shared server, a good opportunity to change that ;)

Live preview hacked.

Can’t purchase it before to try it sorry.

Yes thanks, we’re currently moving the demos away from a shared server and will update the links when done.

I am interested in your plugin and want to see it live. please renew links Or… for example… add some screnshots of forums, groups and widgets

Thanks for asking, while we’re setting up the new demo pages you can have a look at the Documentation pages and feel free to ask if you have any questions on a particular feature.

well… yes… there are no frontend screens… so here are my questions:

Do you support capabilities to read, create and reply on a per forum base for each user grp > different capabilites for a group on specific forums like:

Membergroup 1 Forum 1: can see, create but not reply Forum 2: can not see, not create and not reply Forum 3: can see, create and reply

Membergroup2 Forum 1: cann see, create and reply Forum 2: can see, not create but reply Forum 3: can see, but not create and reply

Hi,

There are front end screenshots on this page http://www.itthinx.com/documentation/groups-forums/using-groups-forums/ for posting a topic and leaving a comment.

Based on what you describe, the permissions you consider might be too fine-grained for what is possible to do with the plugin … you can restrict users to post topics in forums by group and set comment restrictions as seen on http://www.itthinx.com/documentation/groups-forums/setup/

If you’d like to try it on your test installation before deciding, please PM or email support at itthinx dot com with a link to this conversation.

Cheers

Hey Kento,

Demo does not work..

Best regards, Bruno :)

Thanks, yes, setting up a new one :)

Does this still work?

Yes it does :) New demo is online now as well.

The Join the X Group and Leave the X Group buttons are not appearing on mobile devices. Any fix/workaround to this?

You would probably have to review your theme to check how the buttons are rendered, note that this question is not related to Groups Forums but to Groups itself – if you want to provide details on your setup please feel free to post on the Groups plugin page http://www.itthinx.com/plugins/groups/

The demo doesn’t appear to work at all. There’s no way to login to submit a post. There’s also no examples of the forum, threads or anything.

Sure it does. You must register a test account to access it. And it’s pretty clean because it’s been recently wiped.

There’s no prompt to register or explanation on the demo.

Hi there, Can you please explain where I can find the code that should be in the content.php file that is referenced by get_template_part( ‘content’, get_post_format() ); in both single-topic.php and taxonomy-forum.php – I have installed this plugin and the forum page and topic page are not displaying any content! I can’t find the php file for the template part anywhere!

Thanks

Tim

Thanks for the reply. I am pretty sure there is something to do with the way that the warp7 framework by yootheme works that is causing these problems, do you have any experience integrating with that framework?

I will have a look at that documentation again and see if I can spot what I need.

I have made a request for a custom theme via the email address on that page, please let me know if you can help out with a custom theme… Thanks!

Hi Tim,

I’ve just forwarded the adjusted template files to you.

Cheers, Kento

Hi, I bought your plugin an set it up .Is very nice. All I need is a simple forum nothing complicated. The functionality looks and works just fine. There are however some problems with some of the pages and how they display. This is a list of the pages and what they are displaying:
  • forums – views with template selected for that page with a forum sidebar widget
  • select a forum and it returns with a full width page template(no Sidebar), blog sidebar content at the bottom of the page.
  • submit a topic – views with template selected for that page with a forum sidebar widget
  • search a topic – returns with blog page template with the blog sidebar widget
  • selecting a topic – returns with a url website/topic/wood/ with a full width page template(no Sidebar), blog sidebar content at the bottom of the page.
  • select a topic tag – returns with url website/topic_tag/the-tag the blog page template and blog sidebar

The weird thing is when I select a topic the breadcrumb trail shows home>topics>whatever topic and if I click on topics it shows me topics on a blog page with a blog sidebar

I am using the Adrenalin theme. the site is still being put together but near completion. It looks great with this theme. My site has a blog and a forum. They cannot use the same sidebar since the forum is for members only and it really makes little sense anyway. I think I set this up right. I have made minor changes to css here and there but this is a bit out of my reach. Can I be missing something? either way how can I get this to work the way I want it to? I tried to get into your site to submit a support ticket but the site was not working.

Thanks, John

Hi John,

Thanks for the detailed explanation, is it correct that the main point you need help with is to change the template for a topics archive? If yes, then you will find the Themes page from the documentation useful – http://docs.itthinx.com/document/groups-forums/themes/ – as you can see, you can change the templates and for example exclude the sidebar. It really depends on the way the current template is set up, you can create a specific one if you follow the guidelines for themes. You probably know these basic resources already, but in case they result helpful, the pages on template hierarchies and intro on templates on wordpress.org are https://developer.wordpress.org/themes/basics/template-hierarchy/ and https://codex.wordpress.org/Stepping_into_Templates

If you need any specific help with adjusting the theme templates for forums or topics, we’d be happy to help. Can you please also provide a link to you site in that case?

Where can i see changelog?

It’s inside the plugin zip file – changelog.txt

Hi, thanks for asking but that would not be interesting at the moment.

donmope

donmope Purchased

HI there, I purchased the Groups Forums plugin on the weekend. My problem is that my comments don’t show up either on the front-end or in the admin area. The strange thing is that the comment count gets displayed correctly (both on the front end and in the admin area under Comments) but the list of comments in the admin area under Comments is empty – it says “No comments found.” while at the top of this page it says All (X), Pending (Y), Approved (Z) etc correctly showing the number of comments. When I deactivate the plugin the comments show up properly in the admin area under comments and I can edit, delete etc. them. I’m running Wordpress 4.5.2. Please let me know what may cause this issue and how I can solve it as soon as possible. Thanks, Peter

donmope

donmope Purchased

OK, I removed all plugins, switched to the default Twenty Sixteen theme and did a reset on the Database using the WordPress Reset plugin. I then installed Groups and Groups Forums only. Then I created a test forum and a test topic and added a comment on the topic page. The comment still doesn’t show either on the front-end (topic page) or on the back-end (neither the Edit topic page > Comments section, nor the Comments page). The counter works fine – it says “Approved (1)” but the list is empty and says “No comments found.”.

The comment is visible in the database through phpMyAdmin (comment_content – what I have typed in originally, comment_karma – 0, comment_approved – 1, comment_parent – 0, comment_type – empty).

Are there any specific versions of Wordpress, PHP and SQL that are required for the plugin to work? I’m using Wordpress 4.5.2. The server is running PHP 5.4 (native). Server version: 5.6.29 – MySQL Community Server (GPL), Database client version: libmysql – 5.1.73.

Please help solving this – it’s driving me crazy! Thanks, Peter

Hi, thank you very much for the details on the issue and for taking the time to test it with the configuration you describe. Please excuse the delay in responding, could you please send us admin access to the site to support at itthinx dot com so we can have a look at the detailed settings and try to replicate it? Many thanks

donmope

donmope Purchased

Hi, I sent you an email with access details to the site and some other comments. Looking forward to hearing back from you. Many thanks, Peter

by
by
by
by
by
by