CodeCanyon

GoCardless for WordPress Plugin

GoCardless for WordPress Plugin

PLEASE NOTE that if you are using GoCardless for the first time, you will need to purchase the GoCardless Pro plugin and not this one. This plugin will only work for existing GoCardless users who use the legacy API. Whilst the legacy API is still supported by GoCardless (and is still fully-functional), new users should use the latest GoCardless Pro API and the GoCardless Pro plugin.

Want to See More?

Visit the demo site where you can see how easy it is to set up and pay with GoCardless and follow a transaction through the payment system.

Version History

  • v2.1.2 – 04 August 2016 – Updated Help & Usage Intro page
  • v2.1.1 – 17 April 2015 – Removed the superfluous constructor
  • v2.1 – 10 December 2014 – Updated GC libraries (same version number 0.4.2 at GC), amended admin notice and oncluded option to dismiss admin notice
  • v2.0.1 – 24 September 2014 – Fixed payment set-up bug
  • v2.0 – 18 September 2014 – NYOA added, Euro processing made available, made translation ready, 3x WP action hooks, better formatting of admin area, online help, plus some general code tidying
  • v1.8 – 16 January 2014 – Updated GoCardless PHP library to version 0.4.2 from 0.4.1
  • v1.7 – 20 November 2013 – (not a public release)
  • v1.6.2 – 04 December 2013 – GC library updated as changed but not given new version number!
  • v1.6.1 – 09 September 2013 – small bug fixes
  • v1.6 – 05 July 2013 – reworked the confirm section to provide conditionals. Added shortcode buttons to the visual editor
  • v1.5 – 06 June 2013 – updated GoCardless libraries to version 0.4.1 and included an admin page for one-off bills
  • v1.4 – 10 May 2013 – updated GoCardless libraries to version 0.4.0
  • v1.3 – 13 March 2013 – pre-authorizations added and admin area improvements
  • v1.2 – 18 February 2013 – added styling class to payment link
  • v1.1 – 16 January 2013 – subscriptions management added
  • v1.0 – 12 October 2012 – initial release

Tested and working great with WordPress 4.6.1

by
by
by
by
by
by