Discussion on AngularJS CRUD Table Directive

itswadesh

itswadesh does not currently provide support for this item.

13 comments found.

Hello author, Could you provide a clear tutorial to set up and get started? I couldn’t follow the instruction. Or please make a video of it. Thanks.

Just released the how to install video at https://youtu.be/KQteovedgJc

Thank you so much!! I’m waiting for the MySQL support.

Just launched the MySQL version of CRUD Table with Matrial Design

Can I install this app in heroku and MongoLab? For personal use…

Thanks. I uploaded the server folder but i obtain this message: ! Push rejected, failed to detect set buildpack https://github.com/heroku/heroku-buildpack-nodejs#v83 More info: https://devcenter.heroku.com/articles/buildpacks#detection-failure

:(

Any Suggestion?

I have one question… Can I create others categories ex: Name, Surname, Mail… etc…? Thanks you for your patience.

Hello, 1# In past I’ve experience with openshift and it works perfect there. I could not get a chance to test it with heroku although it is designed to be work over there. Currently my heroku account is not working as expected. I will inform you once its up about the issue.

2# Yes you can create other categories. Add those columns into the server/api/student/student.model.js

I’m working on version #2 of this crud table script which will have both nosql,mysql support and will be based on google’s material design.

Thank you!

Hello, I need to customize the CRUD directive, How can I download the code ?

Hello Richard, Sent you the link

Hello, I need to customize the CRUD directive, Can you resend the link ?

Link Sent

Sorry It’s me again. I can’t see the grunt and bower file, so why to use bower install?

And, I don’t know how insert the CRUD directive if I don’t have it

I waiting for you awnser. I want to use in a project, this is stop it waiting the directive

Hello Richard, Please send an email to support@codenx.com . I will reply you with the development version. There you will have the full control

can i install it on windows 7 ? i ve a 8 M lines DB is it possible to read it ?

Yes you can install it on windows 7. I’ve not tried it with such a huge database, but it should be fine.

I’m having issues with the install. I’m missing the grunt file for sure…. Do you have the dev version you could send me?

It was a node-pre-gyp build failure…..I’ve resolved….Environment issue…thanks

had to install newer version of sqlite3 version ….package.json includes older version that breaks on install with newest node version

I am going to update this shortly

Hello, I installed and ran your package in a Centos 7 VM with Node 0.12.9, but unfortunately the GruntFile and Bower.json file aren’t at the folder that I downloaded from codecanyon.

What’s the problem?

Send me an email. I will send you the development version

hello, can you add csv data import feature?

We currently do not have such idea. I have added this to my feature list.

Please give me instructions on installing this under Windows 10 with SQL Server Express 2014. Also, if you have any hints about using it with ASP.NET MVC 4 please send them. Thank you so much.

Hello Scott, Please follow the steps provided in the documentation. It should work well with ms sql server too. Just change the login credentials at

server/config/environment/development.js file

If the issue persist, please do come back with the error message.

can i get dev version?

i cant find bower and grun files. Can you help me?

and i have error with install sqlite3 with node 5.4

Send me an email. I will share you the latest repo

Hi. I receive the following error:

npm ERR! 404 Not Found npm ERR! 404 npm ERR! 404 ‘­g’ is not in the npm registry. npm ERR! 404 You should bug the author to publish it npm ERR! 404 npm ERR! 404 Note that you can also install from a npm ERR! 404 tarball, folder, or http url, or git url.

npm ERR! System Linux 4.2.0-27-generic npm ERR! command ”/usr/bin/nodejs” ”/usr/bin/npm” “install” “­g” “bower” “grunt­cli” “yo” npm ERR! cwd /home/lordoracle/Descargas/proyecto npm ERR! node -v v0.10.25 npm ERR! npm -v 1.4.21 npm ERR! code E404 npm ERR! npm ERR! Additional logging details can be found in: npm ERR! /home/lordoracle/Descargas/proyecto/npm-debug.log npm ERR! not ok code 0

Hi.
Did you do
npm install -g grunt-cli bower
 npm install 
 bower install 

Yes…

lordoracle@lordoracle-desktop:~/Descargas/proyecto$ sudo npm install -g bower grunt-cli yo [sudo] password for lordoracle: npm WARN engine yo@1.6.0: wanted: {node“} (current: {node“}) npm WARN deprecated lodash@2.4.2: lodash@<3.0.0 is no longer maintained. Upgrade to lodash@^4.0.0. npm WARN deprecated npmconf@2.1.2: this package has been reintegrated into npm and is now out of date with respect to npm /usr/local/bin/bower -> /usr/local/lib/node_modules/bower/bin/bower npm WARN engine deep-extend@0.4.1: wanted: {node“} (current: {node“}) npm WARN engine deep-extend@0.4.1: wanted: {node“} (current: {node“}) npm WARN engine hawk@3.1.3: wanted: {node“} (current: {node“}) npm WARN engine hoek@2.16.3: wanted: {node“} (current: {node“}) npm WARN engine boom@2.10.1: wanted: {node“} (current: {node“}) npm WARN engine cryptiles@2.0.5: wanted: {node“} (current: {node“}) /usr/local/bin/grunt -> /usr/local/lib/node_modules/grunt-cli/bin/grunt /usr/local/bin/yo -> /usr/local/lib/node_modules/yo/lib/cli.js

> yo@1.6.0 postinstall /usr/local/lib/node_modules/yo > yodoctor

/usr/bin/env: node: No existe el archivo o el directorio npm WARN This failure might be due to the use of legacy binary “node” npm WARN For further explanations, please read /usr/share/doc/nodejs/README.Debian

npm ERR! yo@1.6.0 postinstall: `yodoctor` npm ERR! Exit status 127 npm ERR! npm ERR! Failed at the yo@1.6.0 postinstall script. npm ERR! This is most likely a problem with the yo package, npm ERR! not with npm itself. npm ERR! Tell the author that this fails on your system: npm ERR! yodoctor npm ERR! You can get their info via: npm ERR! npm owner ls yo npm ERR! There is likely additional logging output above.

npm ERR! System Linux 4.2.0-27-generic npm ERR! command ”/usr/bin/nodejs” ”/usr/bin/npm” “install” “-g” “bower” “grunt-cli” “yo” npm ERR! cwd /home/lordoracle/Descargas/proyecto npm ERR! node -v v0.10.25 npm ERR! npm -v 1.4.21 npm ERR! code ELIFECYCLE npm ERR! npm ERR! Additional logging details can be found in: npm ERR! /home/lordoracle/Descargas/proyecto/npm-debug.log npm ERR! not ok code 0

I’m unable to trace out the error. Can you please email me your server access credentials so that I can checkout whats happening.

Not clear from previouse comments. What is the problem to use it with mySQL?

ok. this crud has got minified scripts. Please purchase https://codecanyon.net/item/mcrud-materialized-database-crud-generator/14617925 . This will have full source code and you can minify yourself too.

it has no sense to buy it if there are no editable source code. Will get money back and then consider next purchase.

sure. for that reason I have already approved your refund request.

Great work, nice colors!

Thank you

by
by
by
by
by
by