CodeCanyon

In Chat - WordPress Plugin for users to chat

In Chat - WordPress Plugin for users to chat

What is InChat?

It is a WordPress plugin that lets your website’s registered users chat with each other. It comes packed with lots of features, some of them are described below. Its look and feel looks similar to facebook.

  • Supports Emoticons and HD emoticons, 3 packs are provided by default
  • Supports file attachments during chat
  • Supports custom contact list creation method by sending chat requests(like friend requests on facebook)
  • Everyone can chat from admin panel too! chat with users while working on your website!!
  • 10 color themes to change the user’s mood.
  • Very less server resource usage by using browser cache storage engine.

Can i run it on shared hosting?

Yes. This plugin does not involves anything that requires additional configuration to run. In fact, it is espicially designed to run on slow servers.

What are the basic requirements?

  • WordPress 4 or above
  • PHP 5.0 or above
  • MySQL 5 or above

InChat version 2.0 – Changelog

  • UI(user interface) is rewritten
  • Themes are now supported, 10 default color themes added.
  • Smiley and HD smiley packs, 3 are provided with the script more can be downloaded from our servers.
  • File uploads during chat is added.
  • Users can change their chat profile picture exclusively, without going to gravatar.
  • Smiley and HD smiley packs, 3 are provided with the script more can be downloaded from our servers.
  • Uses browser cache mechanism, reduced server load by 66% as compared to inchat v1.
  • Uses can go offline, previously they could not.
  • Biggest change : custom contact lists, which can be activated by admin so people can create their own custom list of contacts by sending them contact requests.
  • Admin have option to choose, whether chat list will have all users to chat or custom contacts.
  • If people were added using custom contacts, then they can be removed.
  • chat history stays forever, until users from both side delete it.
  • Support for Internet Explorer 8 or below is no longer provided.
by
by
by
by
by
by