Custom Date Display Module for OpenCart (vQmod)

Easily change the way Dates and Times are displayed!

The Date Display Module for OpenCart (vQmod) is designed to offer an easy way for store owners to change the way dates and times are displayed globally across their storefront. Rather than having to manually edit the master language file for both the admin and the frontend, this module dynamically creates an easy way to modify the date format displayed in both sections, all from the standard Settings panel within the OpenCart administration.

Using standard & native PHP Date/Time notation (http://php.net/manual/en/function.date.php), store owners can easily change the date to be displayed in any format they desire. Once the Admin settings have been saved, returning to the Settings panel will reveal the current date & time in the chosen formats so that the store owners can see how the dates will be formatted across the system without having to manually check each location.

To see a demo display of how the dates are shown across the admin section, please navigate to the following URL and log in with the provided demo credentials. You will not be able to modify the settings panel with these credentials however, for the security of the demo system.

Utilizing vQmod for OpenCart, this module contains only a single file to be uploaded, and does not modify a single core file of the OpenCart system. Instead, using the vQmod system, it dynamically injects the necessary code into a cached version of the core files allowing for complete native functionality, while still maintaining the ability to update the OpenCart system without worry of overwriting any changes made by this plugin.

Requirements

This module was built and tested using OpenCart version 1.5.3.1, and vQmod version 2.1.6, and installed and tested on OpenCart version 1.5.4.1, and vQmod version 2.2.1. While there should be no problem using this module on previous version of OpenCart in the 1.5.x series, or vQmod in the 2.x series, we cannot guarantee any other specific combinations of software versions will be compatible. Should you have any issues installing or using this module, please contact us through our CodeCanyon author page so that we can offer any suggestions or fixes that may be required.

vQmod is absolutely required to use this module! Please make sure you have vQmod installed on your installation of OpenCart prior to attempting to use this module. vQmod is a free download.

What’s Included

Included with this module is a vQmod Module file which is to be uploaded to the XML folder of the vQmod installation.

Change History

Version 1.0.0 (current)
  • Initial software release
by
by
by
by
by
by